PanelDue won't let me set extruder temp…



  • I'm running a Duet WiFi with 1.20beta1, 1.93 WC, and the latest PanelDue firmware. When I tap the extruder temp I'm able to increase the temp using the +5 button. When I go to press the Set button, the PanelDue either ignores the command or jumps to the Move dialog each time. Everything else I've been using works okay so I don't think it's a screen calibration.

    Thanks,
    John


  • administrators

    When you say "ignores the command", do you mean that it doesn't bleep and it doesn't clear the temperature adjustment bar?

    If so, that sounds like the touch membrane is sluggish at that particular point. Try touching it with your fingernail, not the pad of your finger. If that doesn't help, you may need a new TFT panel.



  • I tried my fingernail and it worked. By "ignores the command" I meant that it returns to the main screen without doing anything.
    Thanks!


  • administrators

    Worth noting that the resistive touch membrane on PanelDue responds to pressure, hence the tip of a fingernail (or a stylus) works well and is more precise. Whereas the capacitive sensors on smartphones respond to proximity, so you need to use the pad of your finger.



  • I had the same issue. My first tool was T1. I could not set a temp using the touchscreen. the setting was ignored exactly like you state. When i change my tool definition so the tool was T0, it started working.



  • Okay, discovered there's still an issue here. My printer is a delta diamond mixer and has 4 tools defined (Tool 0 - Tool 3). The problem is that when I set the temp for HotEnd 1 on the PanelDue, the temperature doesn't change and remains at room temp. This is after I first turn the printer on. Changing the bed temp though works fine. I took a look at the web interface and you can see what's happening. Setting the HotEnd 1 temp via the PanelDue shows the temp set for Tool 0, but not the others (Tool 1 - Tool 3). Typically, when I set the hotend temp using the web interface, I use the Control All dialog and all the tools are set simultaneously. This works without issue. My guess is the PanelDue defaults to setting the temp for Tool 0 when setting the hotend from the touchscreen, but if Tool 0 is not the current tool you have selected, the hotend temp doesn't change. Tool 3 is my default on startup.


  • administrators

    I've made a note of this and I will look at it again when I work on the next version of PanelDue firmware, which I hope will be next week.



  • Thanks!



  • Will you add the (Manual Calibration Option), when using P0 for those of use without a zprobe or temporarily without a zprobe dc42 🙂 Hopefully 🙂


  • administrators

    Yes, that's on the list for the next version.



  • Awesome!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.