Pause.g & resume.g : What am I doing wrong?



  • I've had good success with RRF for some time now. To preface this, I'm running a custom core-xy bot on a RADDS board, with RRF 1.18.
    Figured I should get these macro's tuned in, but… I'm experiencing problems.

    pause.g behavior is exactly what'd I'd expect: Fan turns off, bed lowers slightly, nozzle goes to bed home.
    resume.g, not so much: Toolhead travels on XY just above the 'last print spot'. Then it lowers on Z to the 'last print point', but it seems to keep going directly into my print by maybe… an extra .5 mm or so, and makes a mess of things.

    I've tried many combination of values for the past hour+, and either they don't help, or make things worse.
    Printing, works just great. But I'm not sure what to do about this unpause issue. I've compared these scripts to a bunch of the ones that came in the git repro... its basically doing the same thing.
    I'm also running auto-bed leveling before the print starts via G32 (via a bunch of G30's in bed.g), if that could have any sort of conflicts?

    [[language]]
    ; pause.g
    M106 P1 S0        ; Turn off filament cooler fan.
    G91               ; Relative XYZ moves.
    G1 Z3 F300        ; Lower bed 3mm to clear any print artifacts.
    G90               ; Absolute XYZ moves.
    G1 X0 Y0 F5000    ; Move head out of the way of the print, back to bed home.
    
    ```–
    

    [[language]]
    ; resume.g
    G1 R1 Z3 F2500 ; Go to last print point as defined in pause.g aka M25, with a 3mm Z offset.
    G1 R1 F1250 ; Lower nozzle to resume point <- This is where the problem is
    M106 P1 R1 ; Set fan to speed it was paused at.


  • administrators

    You must be running firmware 1.19. The upgrade notes from 1.18 to 1.19 cover this. You need to add parameters X0 Y0 to the first G1 R1 command, and Z0 to the second.



  • Derp, I must have somehow missed that upgrade requirement, thanks David. Will upgrade soon! 🙂



  • Updating to 1.19.2 + adding that extra code fixed it, so thanks for that! Pauses/resumes like one would expect now. Plus I can confirm 1.19.2 works fine on RADDS (thus far). The only change I need was to my Y-stepper direction, per the notes for CoreXY machines.

    But more exciting for me, is that this was the first firmware update that allowed me to do it via M997 S0 : Up until now, that simply "didn't work" for my RADDS board, and I had to use the 'manual technique of using a half-broken Popsicle stick to hit the internal reset button on the Due', which also involved an annoying process inf digging the board & its wires out of it's case. Anyway, that's a thing of the past now, really made my day 😉


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.