I think I broke it…



  • Hello all, please I need your assistance. I think I might have done something that messed up the PanelDue. The touch screen is not responding. The only buttons that seems to work are "stop", "home", "sd card" and "control".

    What I tried:

    • PanelDue firmware update. Used the interactive Bossa and got the "very succesfull" report. But doing this didn't solve the issue.
      Now it's stuck at "touch the spot" (the top center one) and it doesn't respond when I touch it.
    • All pins look good. None of them are loose, broke or burnt.

    What might have been the cause:

    • I made a 25cm long dupont extension cable because I wanted a slim look touch screen. I know, I'm f..king stupid. Each cable was checked for continuity 3 times and I pay an extra attention when connecting it to the pcb.
    • The PanelDue worked fine with the DuetWifi 1.17 firmware. When updated to 1.19 version I didn't connect the PanelDue. So I can't if this problem started with the DuetWifi firmware update or due to this mod… most prob the the last one.

    To sum up, I don't know what else to do, what to check, so any help is much appreciated.
    Martin.


  • administrators

    It sounds like it's only responding to touches at the left hand edge of the screen. My guess is that the connection to the right hand edge of the touch membrane has gone open circuit. Look for where the 4-conductor flexible strip from the touch membrane plugs into the circuit board on the back of the TFT panel, and try reseating it.



  • You are the boss, I removed the ribbon cable from the TFT connector and installed it again.
    It's alive!

    As always, thank you very much David.



  • Well, the issue is the flexible cable, and the touch screen it's responding good now. But I can't explain why it needs to be pressed against the TFT pcb for it to work.
    Watch this video, I'm having trouble explaining it properly:

    https://youtu.be/BvVAHmd0aA8

    To fix it, some kapton tape..


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.