Z Height and probe height procedure needed



  • After stepping away from the BigBox with DuetWifi for about a month, I got the 1.20Beta1 loaded. (yeah and I got wifi working too)

    I re-leveled my bed and ran my Meshbed level macro.

    Now the nozzle is way too high off the bed.

    Please detail the procedure to set the Nozzle height, probe height and store any values in Duetwifi.



  • Measuring the trigger height

    The Z probe trigger height must not vary significantly with XY position. Measure the trigger height of your Z probe at various XY positions and make sure it is consistent. To measure the trigger height:
    1. Make sure there is no filament stuck to the nozzle (you may want to do this test with the nozzle hot)
    2. Cancel any existing bed compensation by sending M561
    3. Send M208 S1 Z-3 to temporarily allow Z moves down to Z=-3mm. This is to ensure that you can lower the nozzle all the way to the bed in step 5.
    4. Command the print head to the XY coordinates you want to probe
    5. Command the print head down in small steps until the nozzle just touches the bed or just grips a sheet of paper. You may need to send M564 S0 to allow movement lower than where the firmware thinks Z=0 is. You may also wish to create a macro to lower the head by e.g. 0.02mm to get greater accuracy (G91 followed by G1 Z-0.02).
    6. Send G92 Z0 to define that height as Z=0
    7. Command the nozzle up 5mm (G1 Z5)
    8. Send G30 S-1 to probe the bed without resetting the Z=0 position
    9. Read off the Z height from the web interface. That is the trigger height.
    10. Repeat the previous two steps a couple of times to make sure you are getting a consistent result
    11. Repeat steps 4-10 for the other XY positions you want to check

    When you have established what the trigger height is, set the Z parameter og the G31 command in config.g to that value.

    On a delta printer, it can be quite hard to achieve a consistent trigger height. Z probes that are mounted on the effector are sensitive to any tilting of the effector, because it affects the relative heights of the Z probe and the nozzle. You can reduce this effect by mounting the probe as close to the nozzle as possible. Probing solutions that use the nozzle itself as the probe are usually not affected by effector tilt, but some types are sensitive to the XY position of the nozzle for other reasons.

    Check Repeatability

    While it is not required to check the repeatability before moving on to the next step of setting up the bed.g file this step can save hassle later on caused by hardware or assembly issues.
    •Position the nozzle about 5mm above the bed, run G30 S-1 to probe, then read off the Z height. Send G1 Z5 and repeat. Do this several times to see how reproducible the trigger height is. At a constant XY position, you are looking for it to be reproducible to within about 2 microsteps at x16 microstepping. That's normally 20 or 25 microns if you are using 1.8deg motors, or half that if you are using 0.9deg motors. I use the IR sensor on PEI and I get consistent trigger height to within 10 microns. If the trigger height is less consistent than that, try a lower probing speed (F parameter in the M558 command). If it still isn't consistent, check whether you have too much friction in your carriage movement and reduce it if necessary. Higher motor current may also help. If that's not the problem, then it's probably down to your Z probe.
    •If that test gives a consistent trigger height, try a similar test but move the nozzle to a different XY position and back again before the G30 S-1 command. If the trigger height becomes inconsistent, suspect play or friction in the joints.



  • UGH! I'm STILL having problems with this. I followed all these steps (yes including step 5 with grabbing the paper)

    My trigger height is 0.38. I set the G31 z parameter to 0.38.

    I ran the Meshlevel macro. The graph shows all red, I cant seem to get better than that with washer shims.

    I tried a small test print. It's printing in thin air. I manually move the nozzle down to grab a piece of paper like i did in step 5.
    The nozzle goes to z-3.80 before it grabs. WHY ? how do I fix this?



  • If you have a config-override.g, make sure that you have the correct G31 Z in there as well. I don't know why, but I have to also include it in my bed.g file in order to get accurate results. Makes no sense to me.

    My steps are…

    Grab a piece of paper with nozzle, G92 Z0.
    G1 Z5 and then G30 S-1 multiple times to get accurate measure.

    Replace the Z in bed.g first, then override.g, then finally config.g and save and reboot.


  • administrators

    @StevenL:

    UGH! I'm STILL having problems with this. I followed all these steps (yes including step 5 with grabbing the paper)

    My trigger height is 0.38. I set the G31 z parameter to 0.38.

    I ran the Meshlevel macro. The graph shows all red, I cant seem to get better than that with washer shims.

    I tried a small test print. It's printing in thin air. I manually move the nozzle down to grab a piece of paper like i did in step 5.
    The nozzle goes to z-3.80 before it grabs. WHY ? how do I fix this?

    It sounds as though your Z homing is a long way out. How are you homing Z?



  • i hit the home button.

    My IR sensor is about 2-3mm from the bed when the nozzle touches it. I havent measured it. Could a more defined IR distance be the issue? what distance SHOULD it be?


  • administrators

    What I meant was, are you homing the Z axis using a microswitch, or using the Z probe?

    In the fitting instructions, I recommend that the bottom edge of the sensor board should be between 1mm and 2mm above the tip of the nozzle. So yours may be a bit high. However, if the sensor triggers reliably before the nozzle touches the bed, it doesn't matter.



  • I use the stock Z probe from BigBox on the carriage.
    There is no Z settings made in bed.g. there is no override config file either.

    what do I do to fix?


  • administrators

    I don't know the BigBox, but I suspect that you are homing Z using a Z max switch and the Z axis length in your M208 command is 3.80mm too low. So whenever you home the Z axis, it resets the Z=0 plane to be 3.80mm above the bed.



  • I finally got it to work!
    I reset the IR probe (that hangs off the carriage) to be 1mm above the bed. I placed a min zip tie under the probe to set the measured 1mm distance.

    Then I followed the steps above. My trigger height was 2.99. There's the 3mm i was looking for!

    So I will need to repeat the steps as I do have my nozzle too close now… so I bet the trigger height will be around 2.90.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.