Doesn't print gcodes and goes to diagnostics mod (Urgent please help!)



  • Hi, I'm using duet ethernet with the latest stable firmware and web interface versions. The problem is whenever I send a GCode to the machine, no matter what the commands are, it just returns a diagnostics message starting with "====Diagnostics===" as if I have sent M122. All the commands in macros work, however. If I copy the same gcode to a macro it works. Does anyone know what is going on?


  • administrators

    Are you sending the command from the web interface? I've seen a few reports of users seeing replies replicated in the web interface, when there have been multiple devices connected to the web interface and one of them has been turned off or put to sleep without disconnecting first. So it may be that you are getting the output from a previous M122 command, followed by the output from the command that you actually sent.



  • Yes, I'm using the web interface for sending the gcodes. I'm using a separate laptop just for running this machine and I don't remember ever sending the M122 command before.


  • administrators

    Does resetting the Duet (e.g. by pressing Emergency Stop) resolve the problem?



  • No, it doesn't. I reset the board and it didn't help. Also, I upgraded to the newest firmware after I saw that issue, and it's still not solved.


  • administrators

    Which exact versions of DuetWiFiFirmware and DuetWebControl are you running? Look on the Settings/General page of DWC to find out.



  • Duet Ethernet: DuetEthernetFirmware-1.19 and DuetWebControl-1.19


  • administrators

    My best guess is that one of the web files has become corrupted. Try uploading the DuetWebControl.zip file through the Settings/General tab. You can use DWC 1.19.3 if you like.

    Also I recommend you upgrade DuetEthernetFirmware to 1.19.2.



  • I found an interesting/annoying bug here! I slice my STL models and save each layer into a different gcode file. When I reach the file that has "layer122.gode" in the name this error happens. It seems for some reason the software confuses those layers with M122 command. When I change the file name it solves the issue!


  • administrators

    I'm glad you pinned down what was triggering the problem. What is the command you were sending that has the name layer122.gcode in it? I'd like to reproduce this problem so that I can implement a fix.



  • I uploaded the gcode to the board through the web interface and just clicked on it and started it.


  • administrators

    OK, but please share the gcode file.



  • David, I sent the file to your email.


Log in to reply