Erroneous Emergency Stop, and very slow bed compensation travel



  • Hi,

    Sorry for starting a new thread. Did search extensively but didn't find my issue.

    I have a new Duet Wifi in a new build (simple cartesian machine). Done about 20 or 30 prints so far, many of which have been unsuccessful for various reasons as I get settings sorted etc.

    But I also have what I think is a bug. When adjusting print speed back to 100% I have several times had the interface do an emergency stop, which is obviously really annoying. Mouse pointer is on "speed factor" slider and emergency stop notification just jumps up and I am done… Anyone else had this? Any ideas how to stop it?

    In case it is related I also get the very slow "tool change" hang error other people have reported before. I only have one extruder so not sure why this should be happening, didn't happen at first.

    Also new, is that the speed of travel between the four corner z-probes (on the basic bed compensation, I have an IR probe) has become super slow. Fairly sure that I didn't change this in firmware but it just suddenly dropped from about 40mm/sec to maybe 10...

    Thanks in advance for any help.

    George


  • administrators

    Which firmware version are you running? To find out, look in then Settings/General tab of Duet Web Control.

    Please post your config.g file.



  • Firmware 1.18.1

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Sep 27 2017 23:21:12 GMT+0100 (GMT Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X535 Y484 Z700 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z0 S0 ; Define active low and unused microswitches
    M558 P1 X0 Y0 Z1 H5 F1500 T900 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X28 Y0 Z0.9 ; Set Z probe trigger value, offset and trigger height
    M557 X100:400 Y100:385 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X53.333 Y53.333 Z2560 E420 ; Set steps per mm
    M566 X1000 Y1000 Z5 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X20000 Y20000 Z200 E1200 ; Set maximum speeds (mm/min)
    M201 X600 Y600 Z20 E500 ; Set accelerations (mm/s^2)
    M906 X1300 Y2200 Z2200 E1400 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S340 ; Set maximum heater temperature to 340C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    M587 Sduet P"" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool


  • administrators

    Thanks for posting that. Some observations:

    1. You are running firmware 1.8.1, which is quite old. Please upgrade to 1.19.2 or 1.20beta 1. Read the 1.18 to 1.19 upgrade notes at https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md first.

    2. In your M558 command you have the T parameter set to 900mm/min, which is only 15mm/sec. This accounts for the slow travel between probe points.

    3. I don't have an explanation for the unexpected emergency stop, so let us know if it still happens after upgrading the firmware.



  • Thanks for the help with this.

    Sorted the slow travel, thanks.

    Bit confused by the firmware upgrade process.
    I only bought this board about two months ago, so to find that the firmware is "quite old" and the upgrade process either incredibly complex or incredibly confusingly documented is pretty annoying.

    The link you gave leads me to think that my best option is to go with 1.19.2, this link has a section on that, but then says if upgrading from 1.18.2 or earlier (which I obviously am) see notes for upgrading to 1.19.0… then under that section it sends me to another webpage for more important notes on getting to 1.19.0 (presumably).

    This is very confusing and daunting.

    Do I need to fully upgrade to 1.19.0 following these earlier instructions and then do all the instructions for 1.19.2

    And would asking for a link to the firmwares in question be asking too much? Is there a clearer set of instructions somewhere maybe?

    George


  • administrators

    You can upgrade directly to 1.19.2 using the same procedure as for upgrading to 1.19. The upgrade from 1.18 series to 1.19 series firmware on the Duet WiFi is unfortunately complicated, it's usually much simpler.

    See "Where to get Duet firmware and tools" on the wiki for the links, and "Updating main firmware" for the instructions.



  • Unfortunately this is proving proved to be a pain in the neck.

    Took SD card out of board (while off)
    Pasted new files from 1.19.2 firmware into position as outlined here https://duet3d.com/wiki/Upgrading_to_DuetWiFiFirmware_1.19 for 1.19.
    Moved SD card back and followed instructions there to install new firmwares.

    Obviously at this point I then had no way of knowing what was going on in terms of rebooting so left it 15 minutes then turned off, connected by USB and turned on again then fired up Pronterface.

    Tried to follow next step of sending the command "M98 P/macros/SetNetwork" but I think I hit the Pronterface auto capitalisation problem as it then told me it couldnt find that macro file…
    Also tried going in using YAT but I cant install YAT as there is a hang on the net framework installation that it wants installed..

    Finally found another thread where reference was made to editing marco files using notepad++ so wondered if the format of windows generated text files was off so redid them using that and bingo..

    Pretty annoyed by this whole process and the quality of the instructions to be honest. If boards sent out within the last 2 months are multiple firmwares out of date, then clearer update instructions that dont require burrowing down through multiple webpages would be nice...

    Will keep you updated on whether the original issue returns



  • So now I cant run auto bed compensation (just probing the four corners to check for level) because it comes up with:-

    JavaScript Error

    A JavaScript error has occurred so the web interface has closed the connection to your board…. please contact the author..

    Message: Uncaught TypeError: Cannot read properly 'getExtension' of null
    URL: http://192.168.0.41/js/dwc.js
    Line: 12:71278
    Error object: {}

    Help please!


  • administrators

    Is this problem reproducible?

    Please report your main firmware version and DWC version, as displayed on the Settings->General page.



  • I cant get anything except the error so yes its reproducible

    It probes the corners OK but then instead of popping up the window with the results it gives the above error.

    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.19.2 (2017-09-01)
    WiFi Server Version: 1.19.2
    Web Interface Version: 1.19


  • administrators

    Please upgrade to DWC 1.19.3 available here https://github.com/dc42/RepRapFirmware/blob/dev/Release/Duet-WiFi/Edge/DuetWebControl-1.19.3.zip (follow the link, then press Download) and see if the problem still occurs.



  • So I updated that by changing the existing www folder to wwwold and creating a new www folder with these files in.

    Now when the auto bed compensation runs, the pop-up window does appear and no java error message, but the display itself is a messed up large black cross of background and no image or data displayed, pressing "top view" button or using any mouse controls have no effect. "Close" works though.

    Possibly related, when I put the SD card in the PC's card reader to put these files onto it, the PC came up with "there's a problem with this drive" and wanted to scan and fix it.

    George


  • administrators

    If your PC thinks there is a problem with the SD card, I suggest you let it fix the card. Better still, copy the files off it, reformat the card, and copy the files back on.



  • Fixing errors it didn't find any. Reformatted card still doing it!

    Reinstalled Java which seems to have sorted it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.