PT100 weirdness



  • So after another rebuild of my BigBox I was about to calibrate the heaters.
    But somehow I had problems with the temperature readings at least on the left hotend. I got temperature errors and was not able to get beyond 200° C.
    So at first I thought the heater is damaged and changed it but again same error. So I changed the PT100 and now I have have real strange things going on.
    On the left hotend I have a new generation PT100 by E3D, two blue cables with a molex connector, and on the right one an old style one that came with the BigBox, silver cable with one white and two red in it.
    When I start he print the left shows a temp of about 19° while the right one reads 21°. Well that might be ok.
    But when I heat up left one to 200° C it seems it is much hotter because Edge or XT I loaded into it just flows out like water and starts boiling. On the right side all seems fine even both read 200° C.
    To check I switched off the box and measured the resistance with my multimeter and left read over 215 Ohms which means it was over 300° C! Right side showed the value correct about 175 Ohms. But on the right side I have now the problem even I did a tuning that I can't get beyond 200°, if I try I get a heater error saying temp is not rising fast enough.

    At the moment I am out of ideas what to test or check. I am on the latest stable release which is 1.19.2 I think.

    I have to admit that I didn't print a while with the box and can't remember when I did my last successful print and which firmware I used then…

    Any ideas?


  • administrators

    My best guess is that you have leakage or a short between the PT100 wires and something else, such as the hot end metalwork. Perhaps even inside the PT100 cartridge when it is hot.

    You can test the PT100 daughter boards by connecting a resistor in the range 150 to 220 ohms directly to the daughter board (with the jumpers or link wires in place if you are using a 4-wire connection).



  • Thanks, going to checkt he daughter board first.
    I have one spare PT100 of the new gen, well it was one of the first new gen that why cables are blue. Now they seem to be red according to the E3D Wiki and shop…



  • Ok a resistor reading 221.7 Ohms on my multimeter gives me a temp of 199.7° on port 1 and 293.9° on port two of the daughter board…
    This sucks... Think I gotta get a new daughter board...


  • administrators

    Indeed it does. It's strange that it appears to read correctly at room temperature. Are the links or jumper wires secure?



  • I made a solder bridge, I can just hit them again with an iron to sort that out and measure resistance between the ports…



  • Ok checked and the res between 1-2 and 3-4 is 0.3 Ohms…
    It seems the error is increasing the more the resistance to measure is so that’s maybe why the error at room is just 2° and a lot more at targeted 200°...



  • Offtopic: when will the IR sensor be back in stock? If I have to order a new daughter board I would like to get a new version of the IR too…


  • administrators

    I shipped a new batch of IR sensors to t3p3 yesterday, so very soon if not already.



  • Just one last question: can I now absolutely be sure it is the daughter board and not something with my DuetWifi?
    Or can I check something else?

    I did a print yesterday, killed heater 2 and the tool for it and wired heater 1 PT100 to the working port of the daughter board and it seemed all fine.
    I clamped two almost identical resistors to the ports and had a difference of almost 100° C between both…


  • administrators

    Assuming that you had nothing except the resistor (+ possibly link wires) connected to the daughter board terminals, that does sound like it's the MAX31865 chip on the daughter board that is at fault, unless there is an obscure firmware bug that nobody else has come across.



  • Ok thanks… Going to order a replacement...



  • Hmmmm so my new daughter board arrived last week.
    I mounted it and all seemed fine. Tested with resistors first, both 220 Ohms, both read ~316° C.
    Ok so up for a print, worked, did come calibration, next print.
    And this one failed, second hotend didn't extrude because of a heater error. Temp reading was 2000° C. So I moved the second hotend by hand and I had a fine reading again, I moved the PT100 cable near the hotend and bam again 2000° C.
    So I assumed a damaged cable.
    Switched the PT100 whic was still the original BigBox old style in silver cable one to a new E3D one just like on the first hotend.
    At room temperature first read 21.7° C, new one 17.1° C. Didn't think much about it just ran PID tuning and now again the filament boiled out of the hotend. The heater reached "240° C" what I wanted to tune but apparently was hotter.
    So back to resistors in both ports of the daughter board and…..
    316° C on the first, 206° C on the second.
    Can this be?! Another damaged chip on the daughter board in just under one week and litterally no usage?
    I checked my cabling, all fine, no problem, no accidentially shortage or possible voltage on the PT100 ports...

    This sucks, now I got my box mechanically fixed and in a shape I like and now I have electronic problems...


  • administrators

    I find this very strange:

    • Your report of a faulty daughter board is the first one I've ever seen.
    • Getting readings differing by 3C when both sensors are at room temperature is most definitely wrong.
    • According to the manufacturer of the MAX31865 chips, the inputs are protected against overvoltage faults of up to +/-45V.

    So at this stage I am considering 2 possibilities:

    1. A firmware bug that is affecting the reading of the second sensor in your configuration. Can you stack your 2 boards together, connect 100 ohm resistors to all 4 inputs, and see what readings you get? Then stack them in the opposite order and compare the readings.

    2. A short or leakage in your wiring or in the PT100 sensor itself, that is damaging the sensor chip somehow, despite the manufacturer's claim that the inputs are protected to +/-45V.

    Can you confirm that in both cases, it is the second channel of the daughter board that has the problem, and it was connected to the second hot end?



  • Will try all later but so far I can confirm that the first board had the fault on port 1, the new one on port 2…
    So not what you wrote, each board a different port affected...



  • Just to add this I used the sensors I replaced for a while also in long prints with the RUMBA and with the Duet later. Now I have two new gen E3D cartridge PT100 mounted I had on my alternate Volcano Hotends which I used with the RUMBA…
    If you say the chips are protected up to 45V I have no idea even if I have a shortage how simple PT100 can damage the chips...



  • Ok I did some further testing.
    I prepared parallel resistor bundles in the range of about 107-108 Ohms to get a tempereratur about room temperature.
    So on the old board I had 107 on port 1, 107 on port 2, new board 106.4 on port 1 and 108 on port 2.

    I don't tell you all the details, I tested both boards alone and stacked, on the DuetWifi and on the DueX2.
    Always about the same results:
    Old board port 1: 12.5° C
    Old board port 2: 15.8° C
    New board port 1: 16.3° C
    New board port 2: 12.5° C

    So old board port 1 and new board port 2 are off, well port 2 of the old board seems off a little too.
    Port 1 of the new board is the best…

    On the old board I had two old PT100s connected and later on port 1 a new generation E3D PT100, on the new board just on port 2 an old one...
    But again, I can't imagine that a simple resistor (PT100) can damage the chip...

    I could now print using the "good" ports of both boards but still this is a strange situation....



  • Oh BTW out of curiosity I downgraded to 1.18.2 too but also the same result…



  • So any ideas what can be wrong with my setup?
    It worked a long time, I didn't do anything to the cabling as I have fixed cabling from top of the back of the box to the board which I didn't change for almost a year. And the cabling from print head to the connection point is free floating in the air also bundled cabling which I didn't change. All cables are bundled, the PT100 cables from top back are in a sleeve and still the original silver PT100 cables with a heavy isolation and internal metal sleeve… So all that could have happened is a broken cable to the PT100 itself. An inspection didn't show any other cable damaged or contacting the PT100 cables...


  • administrators

    Please ask for your new PT100 board to be replaced under warranty. When you receive it, before you connect the sensors, test both inputs with the same resistor, one at a time. The readings should be within 0.5C of each other, and typically much closer than that.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.