CR-10-4 Flipped print ?



  • I have everything set up for my cr-10-4 ( 400x400x400 )
    Used https://www.duet3d.com/forum/thread.php?id=3145#p28325 as a template and it workes like a charm.
    Had some problems with the endstops but guided by DjDemonD ( thanks ) 😉 i got that solved.

    But when i print , it does so upwards instead of on the bed ?
    It's like it thinks my Z axis is my Y axis ?

    I am pritty new into this so excuse the mess 🐵

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Oct 28 2017 00:02:03 GMT+0200 (Mitteleuropäische Sommerzeit)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X400 Y400 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Define active high microswitches
    M558 P0 X0 Y0 Z0 H5 F120 T12000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X20:380 Y20:380 S20 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M92 X80 Y80 Z400 E99 ; Set steps per mm
    M350 E32 I1 ; Configure microstepping with interpolation
    M350 X16 Y16 Z16 I1 ; Configure microstepping with interpolation
    M566 X1200 Y1200 Z24 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z600 E3000 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z100 E5000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S265 ; Set maximum heater temperature to 265C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PDuetWifi.lan.local ; Set machine name
    M552 S1 ; Enable network
    M587 S"SSID" P"PASSWORT" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S1 I0 F500 H1 T50 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 I0 F30 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off - have 2 Blowers parallel
    M106 P2 S0.5 I0 F30 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off - have 2 Case Fans parallel

    ; Custom settings
    M912 P0 S-13 ; calibrate MCU Temp

    ; Miscellaneous
    M501 ; with PID Tune data
    T0 ; Select first tool


  • administrators

    I may be confusing this with another machine, but is this the one with 2 Y motors, and if so, have you plugged the Y motors into the Z motor connectors and the Z motor into the Y motor connector? If so then you need to tell the firmware that using:

    M584 Y3 Z2

    Put this immediately after the M569 commands. Restart the Duet, then test homing and axis movement very carefully.



  • It ha 2 Z motors. Not 2 Y motors. And they use the same connector,
    I just double cheket my connections, and they are not swapped 😉 .

    It all works fine when i use "home all" and the other axis commands.
    Only when i start print, the wiers stuff start



  • sounds like your Y axis needs to be reversed in your config and then maybe your endstop may need to be redefined to the opposite end of the axis ie min to max or whatever.

    Try
    M569 P1 S1 ; Drive 1 goes backwards

    and maybe if it then homes the wrong way.

    M574 X1 Y0 Z1 S1 ; Define active high microswitches.

    HTH

    Doug



  • Nae that wasn't it .

    My homing works on all axis and they behave as they are supposed to.
    But when i start a print it's whole different story.

    It may be me not explainig correctley . when it prints , it does so upwards instead of flat on the bed ? Like as if the printer was flipped 90 degrees . ( pritty mutch what i wrote before 🙂 but i dont know how to best explain that )



  • Dunno what it was most likely a bad .stl file 😉

    now it works . But thanks for your time

    Happy tinkering or printing 😉



  • ah glad you got it sorted it did seem mighty weird


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.