Rough start with wifi duet



  • Hi all,
    I am trying to switch the electronics of my 3D printer for a wifi duet and I can't get anything working.
    The PCB is a duet Wifi I bought from filastruder (I can't find a part number there)
    The markings on the PCB are DuetWifi 1.02.

    The first time I connected the board to the USB of my mac, nothing unusual happened, the 5V and 3.3V and USB power and diag LED became solid on, the blue LED of the wifi became blue for a few seconds then dark again. When I used USB prober I couldn't find anything on the USB ports. No documentation describe exactly what I should find on the USB ports, but I was expecting a CDC device or some DFU reference, or at least the number of discovered devices to change if I plug or onplug the board.

    I tried a few things, like having a look at the SD card, going on the website to configure the 3D printer and the wifi network, get the configuration on the SD, and rebooting, still nothing (I might have mis-typed something in the WIFI configuration, tho).

    I tried to plug the 12V on VIN (a wiki page was advising that some computer USB ports are not beefy enough), but I still couldn't discover anything on the USB bus, I tried to unplug my mac from the wall to avoid a ground loop, still nothing on the USB side.

    I went to retrieve my Windows PC from the storage, when I plug it in there, windows doesn't give me any notification that a USB device has been plugged in. I tried to download the USB driver from github, but I don't know how to install it, double-clicking on the .ini just opens it in a text editor, and double-clicking the .cat opens some explorer called security catalog that doesn't look like an install program, right clicking on the .cat file doesn't show any install-related verb.

    I tried Erasing the board, but I am not sure I understood the procedure on the wiki (push 1s on erase, release, then push reset? or should there be an overlap in the button presses?), in the hope that I could discover something, anything, on the USB port (some MCU DFU?).

    I checked some voltages, I found 4.69V on the CONN_SD connector, and 3.31V on the CONN_LCD connector.

    I messed a bit with the content of the /sys folder on SD card for a while, but later went on github and put back everything like it's supposed to be when new. I am still not clear if I need the SD card to boot the MCU or if there is a flash inside, I have never used an Arduino.

    Just to be clear I have only connected the USB port and the 12V VIN during my tests, I have not yet tried connecting anything else (I wanted to study the lay of the land before plunging).

    Here is the board as I always saw it during my explorations on USB:

    4 LEDs are on: diag, USB power, 5V, 3.3V

    when I tried the 12V, the VIN LED came on, and the USB power LED is on IFF I plug in the USB.

    I don't know what more to do, I have no oscilloscope, no UART adapter or MCU debug probe, and generally limited tools.

    Does anyone have a next step to suggest? I can't even tell if anything is wrong, my only behavior is "no talking" on my only IO port.

    Thanks for any help, it's been a very frustrating Saturday, and I wanted to finish this project in the week-end.


  • administrators

    Try a different USB cable?

    The LEDs are behaving normally.



  • THANK YOU!

    I had tried 2 USB cables, just in case. After your message I went to scour the house for an active USB device with the same USB socket (that was hard, used my drone, everybody uses USB for energy these days), and tested my cables: not worky worky. Is it the USB prober ? nope it sees my external drive and an external mouse, and I am sure I have configured this drone through USB before. Went to find some other USB cables laying around the house, I found 4 USB cables not working in a raw, only the fifth one had the data working.

    Long story short: thank you, it was the cable. The cables, 4 of them, in a raw.

    (and of course the USB cable provided with the board is still neatly wrapped and in the box 🙂 )

    Thank you, we are back on track.



  • I re-flashed everything (MCU and ESP82) and I am in the Web server in wifi, thanks.

    FYI, the Bossa UI worked in high DPI on a retina mid-2015 macbook pro.


  • administrators

    I'm glad you got it working. I think the issue with Bossa not working on high DPI screens is probably a Windows-only thing.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.