Having trouble setting the z offset



  • I am running the latest stable release firmware, server and web control. I am running a corexy. I have installed a BL Touch probe. It wil home coreectly and does a bed leveling just fine. I just can't adjust the z offset to get the correct z height for printing. I have tried setting it for many different numbers ranging fro -5 to +5 with no change. After I hame homed and run G32, I give G1 Z0 to check the offset and every time it runs the nozzle into the bed and deflects the bed the same amount. What am I doing wrong?



  • Where are you putting that value? (Your G31)



  • G31 X25 Y15 Z5 for example.



  • Yes, but where did you put that?

    Is it in your config.g?
    Is it in your config-override.g?
    Both?

    If it is in you config-override.g do you have a M501 at the end of your config.g to load the override file?



  • It's in the config.g file.
    There is a Config-override file also. It has a bunch of line with heater values and then there is some that deal with ofsets, but it is mostly "0"'s in the offsets.



  • is there an M501 at the end of your config.g? If there is then it may be loading the config-override.g file and using the (zero) offsets from there. That would explain why nothing changes no matter how extreme you change the values.

    The newer firmwares (still in beta) have removed G31 from the config-override.g because this very scenario can be confusing, and a bit redundant.

    For now, I would recommend verifying that you have an M501 in your config.g. You will want that so that it loads any adjustments made by your autocal and saved via M500. Then make sure that at the end of your config-override.g there is a G31 X25 Y15 Z5, or w/e values you need, there.



  • Thank you. I will try that tomorrow. I'm too tired tonight to try it. Should I just move the G31 line to the override file or just copy it?


  • administrators

    Just copy it.



  • OK. Thanks.



  • OK. M501 is at the end of my config.g file. My G31 P50 X28 Y15 Z2 is copied to the config override file. I have tried several different values in the Z and the offset just does not seem to be changing.



  • Have you confirmed the probe is working? I don’t have any experience with BL Touch, sorry.



  • My printer homes with the bl touch as the z end stop fine. I also does the bed compensation and gives a report of the bed after it done the probing. Just can't adjust the z offset. The weird part is, I have installed a Duet Ethernet on a different printer with a BL Touch and that one works fine. I did the install on this Duetwifi the same and can't figure out why the z offset refuses to change. I had this board working with an inductive sensor and it worked, but was not consistent.



  • That is odd. Well if you want to post you config.g and config-override.g files I don't mind looking at them to see if anything catches my eye. Just remember you may want to redact any network names or passwords you have in them.



  • ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Apr 27 2017 06:26:16 GMT-0700 (PDT)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M307 H3 A-1 C-1 D-1

    M667 S1 ; Select CoreXY mode
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y260 Z270 S0 ; Set axis maxima

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S0 ; Define active high microswitches
    M558 P5 X0 Y0 Z1 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 P50 X28 Y15 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X30:260 Y30:250 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes rearwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping
    M92 X79.41 Y79.41 Z400 E385.05 ; Set steps per mm
    M566 X600 Y600 Z24 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z600 E1500 ; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z100 E10000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    ;M579 y1

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 ; Set machine name
    M551 ; Set password
    M552 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M501
    ; Custom settings are not configured

    Config override.

    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A90.0 C700.0 D10.0 S1.00 B1
    M307 H1 A340.0 C140.0 D5.5 S1.00 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 B0
    ; Z probe parameters
    G31 P50 X28.0 Y15.0 Z2.4

    Thanks for looking at it. Maybe you will see something I don't. This Duetwifi is one of the first revision boards with the erase button right on the edge of the board. I initially had problems with the wifi part, but it seems to be working well with the latest stable release of the firmware and server and web control. The config.g file was generated for firmware 1.17, not 1.19.2. Would that be a problem?

    Vance



  • Should your M558 be "P4" instead of "P5"?

    I'm not really sure here, but that is all that caught my eye.



  • That should be P5 for the BL Touch. Thanks for looking.


  • administrators

    @vhoward:

    My printer homes with the bl touch as the z end stop fine. I also does the bed compensation and gives a report of the bed after it done the probing. Just can't adjust the z offset. The weird part is, I have installed a Duet Ethernet on a different printer with a BL Touch and that one works fine. I did the install on this Duetwifi the same and can't figure out why the z offset refuses to change. I had this board working with an inductive sensor and it worked, but was not consistent.

    1. Do you by any chance have your homez.g and Z homing part of homeall.g configured as if you are using an endstop switch, instead of using G30 commands?

    2. Have you checked whether the G31 command in config.g is being overridden by one in config-override.g?



  • The files were all created with the configurator. The homeall.g has never worked correctly and when I look at the file, it is greek to me. When I home all, it starts with the x axis and the x axis starts grinding and slowly moves away from the endstop. I have to either cut the power of press the emergency stop to get it to stop. However, I can home the machine by homing each axis separately. The configurator will not let you configure a z endstop, only a probe. Or I never figured out how to get the configurator to configure a z endstop. This machine operated fine with the inductive sensor I had installed and I could change the z offset no problem. It just wasn't consistent. The G31 line in config.g has the z offset as 0 and the override file has the z offset as 2.4. I have been changing the z offset in the override file as that is what should be being used. They are posted above.



  • For some reason, I can now change the z offset in the config override file and it takes effect now.



  • Well congrats I guess?! That’s odd.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.