Oddity during delta bed calibration



  • Just something odd I've noticed - when I hit auto cal for my delta, one of the points is almost always probed much slower than the others - it looks like it's about half the speed. It's random, too. Not always the same point. The piezo is sensitive enough it's not an issue, it still triggers fine. Just wondering if anyone else has encountered this? It was doing it on 1.18.1 firmware. I just upgraded to 1.20-beta6, and it did it again.

    Here's my bed.g file (I could clean it up some, it has some leftover stuff from experimenting with various z-probes and settings):

    M558 P1 I0 F230 X0 Y0 Z0 T3000 R1 ; F120
    G31 X0 Y0 Z-0.125 P400

    M350 X32 Y32 Z32
    G28
    G1 Z5 F4500
    G1 X0.00 Y119.00 Z5 F4500
    G4 S1

    G30 P0 X0.00 Y119.00 Z-99999 H0
    G30 P1 X59.50 Y103.06 Z-99999 H0
    G30 P2 X103.06 Y59.50 Z-99999 H0
    G30 P3 X119.00 Y0.00 Z-99999 H0
    G30 P4 X103.06 Y-59.50 Z-99999 H0
    G30 P5 X59.50 Y-103.06 Z-99999 H0
    G30 P6 X0.00 Y-119.00 Z-99999 H0
    G30 P7 X-59.50 Y-103.06 Z-99999 H0
    G30 P8 X-103.06 Y-59.50 Z-99999 H0
    G30 P9 X-119.00 Y-0.00 Z-99999 H0
    G30 P10 X-103.06 Y59.50 Z-99999 H0
    G30 P11 X-59.50 Y103.06 Z-99999 H0
    G30 P12 X0.00 Y59.50 Z-99999 H0
    G30 P13 X51.53 Y-29.75 Z-99999 H0
    G30 P14 X-51.53 Y-29.75 Z-99999 H0
    G30 P15 X0 Y0 Z-99999 S6

    G28
    M350 X16 Y16 Z16 E16:16 I1
    G28


  • administrators

    You have selected analog mode (P1) in your M558 command. In this mode, when the Z probe reading reaches 90% of the value specified in the P parameter, it will slow down probing to 1/3 speed. Looks like you are sometimes getting a reading of 360-399 at the start of probing. So either switch to digital mode (P5), or increase the P parameter, or adjust the sensitivity of the probe.



  • Awesome, thanks David! Glad there's an explanation for how random it seemed.



  • Makes sense of this thanks, I've noticed this too. But since it didn't seem to cause any trouble just ignored it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.