Duet WiFi connection problems

  • I have a new Duet Wifi - currently the only connection it has is the micro USB.

    I have upgraded to Version 1.19.2 of the firmware and the terminal shows this after a reboot:

    RepRapFirmware for Duet WiFi Version 1.19.2 dated 2017-09-01

    Executing config.g…M570 S parameter is no longer required or supported
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 275C.

    Network disabled.
    RepRapFirmware for Duet WiFi is up and runni

    As part of the upgrade I changed the macro 'SetNetwork' to the following:

    M552 S0
    G4 P1000
    M587 S"your-network-ssid" P"your-network-password"

    I did set the network SSID and password for mine!

    Next I ran the macro with the command M98 P/macros/SetNetwork and got the response:

    WiFi module started

    Next I ran the command M587 to see what networks it knew about and got this:

    Remembered networks:

    My network SSID is "lilylink" so all ok so far…

    Next command was M552 S1 and I get this:

    WiFi reported error: no known networks found
    Wifi module is idle

    I have been round this loop several times and am now stuck. The Wireless router is less than 2 metres from the Duet in clear line of sight.

    Thanks in advance.


  • administrators

    1. Is your SSID really "lilylink" in lower case characters? SSIDs are case-sensitive.

    2. Please check that your router is transmitting on 2.4GHz, and not just on 5GHz. The Duet uses 2.4GHz only.

  • Hi David,

    Yes, just checked the SSID is all in lower case and the wireless router (Netgear WN802T) is 2.4 GHz only and set to Channel 1.

    I'm just trying again via a laptop to see if that makes any difference, I haven't plugged in the ethernet cable in to the laptop to force it to use the wifi.



  • administrators

    Can you try a different channel e.g. 6? Some users have reported that the wifi module has difficulties with channel 1.

    If you are getting the message "WiFi reported error: no known networks found" then that means the WiFi module hasn't connected to the router, and using a laptop isn't going to help.

  • Ok problem solved - I have been an idiot 😞

    I went back over all the parameters and I was wrong about the spelling of the SSID - it's been a while since I set it up and I was 'sure' I knew the correct name - wrong wrong wrong, should have checked the obvious things first.

    Apologies to David for wasting his time - his first comment was correct, once I got the SSID spelling right it all worked and up came the IP address of the Duet.

    Good news is the linear bearings, belts and carriages from Robotdigg arrived via fedex this afternoon so I can get on with the Kossel build 🙂



    p.s. I have at least got the latest stable firmware installed!

  • administrators

    Glad you solved it!

Log in to reply