How to disable 'gcode update bubbles' in DWC?



  • Duet Web Control is great. But how do I get it to stop spamming the screen with every gocode move it executes while printing? I get these blue floating text-bubbles at the bottom of the screen in a constant stream, sometimes stacking up pretty high cluttering the view. The "estimation" section of the print status tab is obscured 50% of the time because of them. I've looked all over the options, but I can't find way to disable this "feature".
    Any thoughts appertained, thanks!



  • What browser and what OS?

    I'm on a Mac, and with Safari, I rarely get any bubbles. With Chrome, I get bubbles only on messages that I would consider important, certainly not on any GCODE moves.

    John



  • I'm on Windows, Chrome. They have a little "i" on the left side in a blue circle.


  • administrators

    Are they error messages? If so, deal with the error. If they are layer change messages, disabled sending those in your slicer.



  • I think it's simpler than that. In DWC go to "Settings" then press the "User Interface" tab, then uncheck the box labelled "Log any successful G-Code".



  • Not errors (I would deal with those asap, and be glad to be notified) : Every line of gcode that execute pops up in these bubbles. They look like "info" since they have a lowercase "i" in a round circle to the left of each.

    I unchecked the "Log any successful G-Code" feature, but it has no effect on this behavior.

    So, looking at it more closely, it looks like everything that prints to the gcode tab also prints to these bubbles. So if I pause it, a little bubble pops up with the pause command. When I start a print I get that gcode printing. Mainly though, it's a constant stream of M105 responses, like:

    T:190.0 /190.0 B:24.2 /0.0

    So my "every gocode move it executes" is actually incorrect. So, how can I suppress that? I'm more than fine going to that tab if I want to see that info.

    thanks!


  • administrators

    Do you also have Pronterface or another 3D printer host program connected to the Duet via USB?

    Which firmware version are you running?



  • @AK Erik.
    What you describe is exactly the behaviour I see when I check the box "Log any successful G-Code" and unchecking that box removes the pop ups. Did you click "Apply Settings" when you unchecked the box? I didn't make that clear in my earlier post.



  • From DWC:
    Firmware Name: RepRapFirmware for Duet Ethernet
    Firmware Electronics: Duet Ethernet 1.0
    Firmware Version: 1.19.2 (2017-09-01)
    Web Interface Version: 1.19.3

    "Log any successful G-Code" has been unchecked since basically day one. Changes applied: it's unchecked every time I start it.
    I have nothing else connected to it: Ethernet only, only DWC.

    Thanks!


  • administrators

    Do you get this happening as soon as you connect, or does sending a particular GCode command or running a macro trigger it? Or does it happen only when printing a gcode file?

    There are some commands (e.g. M109) which, when received from USB or Telnet and in Marlin emulation mode, cause temperature reports to be sent back once a second until the set temperature has been reached. But those are never sent to the web interface.

    If it occurs when printing a file from SD card, then your slicer is probably inserting M105 commands into the file, and you need to configure it to stop doing that.



  • So…. it's giving me different behavior on a new print:. Zero bubbles popping up. Also zero messages (once the print starts) in the gcode console as well. Completely opposite behavior, but much more to my liking.

    thanks!


  • administrators

    Yes, that setting in S3D would cause that problem, so disable it.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.