DuetEthernet not starting up correctly



  • Hi Everyone,

    My new Rostock Max DuetEthernet system has been working great, until last week when I accidentally damaged my delta smart effector while changing a nozzle. I ordered a new one and installed it carefully, double checking all the connections, grounding myself while working, and making sure not to damage the traces. However, when I turned my system back on, the web interface on my DuetEthernet is no longer available. I have been tinkering with it a while but everything I have tried has been frustratingly ineffective; I still have no idea what the problem is. Here are my observations so far:

    • The lights on the ethernet port do not turn on, ever. Tried USB power only in addition to (and separately from) full 24v power from my mean well supply, and tested different ethernet cables and ports on my main switch. No lights on the ethernet port under any circumstances; it appears to be turned off, although the IC on the ethernet board does heat up.
    • Several other LEDs on the main board light up, including the 3.3v light, the 5v light, and the red LEDs by the stepper drivers. The "diag" LED (what is this?) also comes on sometimes.
    • I reinstalled the fimware using the SAM-BA programmer after m997 S0 yielded the error "Error: Firmware binary "DuetEthernetFirmware.bin" not found" despite the fact that the file was triple-checked to be the right version, with the right name, located in /sys on the SD card. M115 yields the output:
      FIRMWARE_NAME: RepRapFirmware for Duet Ethernet FIRMWARE_VERSION: 1.19.2 ELECTRONICS: Duet Ethernet 1.0 FIRMWARE_DATE: 2017-09-01
    • I tried a couple of versions of config.g, including the one that was working fine before I replaced my effector platform, and a new one generated by the RepRap configurator. Commenting out network settings has no effect one way or the other. My current config.g file is quoted below.
    • M552 with no args states that networking is disabled. M552 S1 causes the serial console output to hang for about 10 seconds, then the board apparently restarts with no explanation, without the network ever coming up before or afterward.
    • According to my router, the board is not sending DHCP requests, nor does setting a static IP in config.g and in the router's reserved address space have any effect.

    I'm worried that my networking module has somehow died… This is frustrating; I really like this board, so much so that I've quickly become dependent on it... so I need it to work! Any help is much appreciated.


    [[language]]
    ; Configuration file for Duet Ethernet (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Nov 20 2017 18:16:38 GMT-0500 (Eastern Standard Time)
    
    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    
    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R144.8 L291.06 B140 H310 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them
    M208 Z0 S1 ; Set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops
    M558 P1 X0 Y0 Z0 H10 F120 T3600 ; Set Z probe type to unmodulated, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 R100 S20 ; Define mesh grid
    
    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 E476.5 ; Set steps per mm
    M566 X900 Y900 Z900 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X21000 Y21000 Z21000 E1200 ; Set maximum speeds (mm/min)
    M201 X750 Y750 Z750 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E1200 I60 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S300 ; Set idle timeout
    
    ; Heaters
    M301 H0 S0.90 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4300 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S150 ; Set temperature limit for heater 0 to 150C
    M305 P1 T100000 B4138 C0 R4700 X202 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 202
    M143 H1 S350 ; Set temperature limit for heater 1 to 350C
    
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Network
    M550 PDUET3D_0 ; Set machine name
    M540 P7A:A1:E5:68:5B:B9 ; Set MAC address
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    
    ; Fans
    M106 P0 S1 I0 F10 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F100 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F100 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Custom settings are not configured
    
    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool
    
    

  • administrators

    It does sound that your networking module has died. Please contact your supplier.



  • Thanks dc42 for confirming what I was afraid was the case. Have you seen this happen before? Any suggestions for how to safeguard against it happening again? Either way, thanks more than I can say for the work you have put into this excellent project.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.