Config.g issue


  • Banned

    Hello I have been working for a month trying to config the printer I built. I posted before mechanic reasons for my setup, but in this post I just want to address the files. I can asure you everything is in order hardware wise. it at least moved around before. I am place my setup info for review. I'm at the end of my road and the whole things gettin scrap real soon. all extrenal drives X is on lcd conn 10, Y is on lcd 11, Z E0 E1 E2 are on the expansion breakout board. Z5 E0:6 E1:8 E2. boards at 24 volts drives at 24 volt. opt iso multi channel for to lcd connector to x,y exp board does it for the other 4 drive. This is something i'm missing in the firmware. I can m80/81 the axt on control fans switch relays verify check ends stops, but no motoring. I read 4.37 volt on dir pins with no drop jogging dir. no pulses being produced be duet ethernet board. I check them with my Tektronix 1052b, and trust me theres no pulsing not even noise. dir is surpising stable at 4.3703 vdc. this board only works with the onboard equipment.Making a button do what you want

    ; Configuration file for Duet Ethernet (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Oct 23 2017 18:51:17 GMT-0400 (Eastern Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X295 Y295 Z207 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y1 Z1 S0 ; Define active high microswitches
    M558 P5 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to BLTOUCH, the axes for which it is used and the probe + travel speeds
    G31 P50 X50 Y10 Z.7 ; Set Z probe trigger value, offset and trigger height
    M557 X35:200 Y35:200 S20 ; Define mesh grid
    M557 R78

    ; tools
    M563 PO D6:8:9 H1 F2
    G10 P0 S0 R0 X0 Y0

    ; Drives
    M569 P0 S1 R0 T1.5 ; Drive 10 goes forwards
    M569 P1 S1 R1 T1.5 ; Drive 11 goes forwards
    M569 P2 S1 R1 T1.5 ; Drive 5 goes forwards
    M569 P3 S1 R1 T1.5 ; Drive 6 goes forwards
    M569 P4 S1 R1 T1.5 ; Drive 8 goes forwards
    M569 P5 S1 R1 T1.5 ; Drive 9 goes forwards
    m584 X10 Y11 Z5 E6:8:9
    M350 X32 Y32 Z32 E32:32:32 I1 ; Configure microstepping with interpolation
    M92 X200 Y200 Z6400 E160:160:160 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X4000 Y4000 Z180 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250:250:250 ; Set accelerations (mm/s^2)
    M906 X0 Y0 Z0 E0:0:0 ; Set motor currents (mA)
    M84 S0 ; Disable motor idle current reduction

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M307 H7 A1 C1 D1
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 P kathryn printer ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory


  • Banned

    next
    Idle

    kathryn printer

    Tools / Heaters
    Control All
    Tool Heater Current Active Standby
    Tool 0
    T0
    Heater 1
    active 23.8 °C

    Tool 127
    T127
    Heater 1
    active 23.8 °C

    Bed

    Heater 0
    off 23.9 °C

    Temperature Chart
    0
    50
    100
    150
    200
    250
    Machine Status
    Head Position X Y Z
    0.0 0.0 0.00
    Extruder Drives Drive 1 Drive 2
    0.0 0.0
    Sensors Vin Z-Probe
    24.4 V 1000

    Machine Control
    Print Status

    G-Code Console
    G-Code Files
    Macros

    Filaments
    Settings

    General
    User Interface
    List Items
    System Editor
    Machine Properties
    Tools

    Drive Configuration
    Drive Endstop hit Minimum Maximum InstantDv Max Speed Acceleration Motor Current
    0 No 0 mm 295 mm 15 mm/s 66.67 mm/s 500 mm/s² 0 mA
    1 No 0 mm 295 mm 15 mm/s 66.67 mm/s 500 mm/s² 0 mA
    2 No 0 mm 207 mm 0.2 mm/s 3 mm/s 250 mm/s² 0 mA
    3 Yes n/a n/a 2 mm/s 20 mm/s 250 mm/s² 0 mA
    4 Yes n/a n/a 2 mm/s 20 mm/s 250 mm/s² 0 mA
    5 No n/a n/a 2 mm/s 20 mm/s 250 mm/s² 0 mA
    6 No n/a n/a 2 mm/s 20 mm/s 250 mm/s² 0 mA
    7 No n/a n/a 2 mm/s 20 mm/s 250 mm/s² 0 mA
    8 No n/a n/a 2 mm/s 20 mm/s 250 mm/s² 0 mA
    9 No n/a n/a 2 mm/s 20 mm/s 250 mm/s² 0 mA
    Z-Probe

    Type:
    Digital Switch (5)
    Trigger Height:
    0.7 mm
    Trigger Value:
    50

    Other

    Geometry:
    Cartesian
    Motor Idle Current Factor:
    30%
    Motor Idle Timeout:
    never

    why are the drive still list in the default way?


  • Banned

    Idle

    kathryn printer

    Tools / Heaters
    Control All
    Tool Heater Current Active Standby
    Tool 0
    T0
    Heater 1
    active 23.9 °C

    Tool 127
    T127
    Heater 1
    active 23.9 °C

    Bed

    Heater 0
    off 23.8 °C

    Temperature Chart
    0
    50
    100
    150
    200
    250
    Machine Status
    Head Position X Y Z
    0.0 0.0 0.00
    Extruder Drives Drive 1 Drive 2
    0.0 0.0
    Sensors Vin Z-Probe
    24.5 V 1000

    Machine Control
    Print Status

    G-Code Console
    G-Code Files
    Macros

    Filaments
    Settings

    8:45:53 PM
    Connection established!
    8:45:40 PM
    Disconnected.
    8:43:22 PM
    M32 0:/gcodes/ethernet setup.txt
    File 0:/gcodes/ethernet setup.txt selected for printing
    MAC: be:ef:de:ad:fe:ed

    RepRap name: kathryn printer
    8:18:04 PM
    M122
    === Diagnostics ===
    Used output buffers: 2 of 32 (8 max)
    === Platform ===
    Static ram used: 24996
    Dynamic ram used: 89564
    Recycled dynamic ram: 128
    Stack ram used: 1104 current, 3784 maximum
    Never used ram: 12600
    Last reset 00:01:08 ago, cause: software
    Last software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Spinning module during software reset: GCodes, available RAM 12528 bytes (slot 0)
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 35.3, current 38.3, max 39.6
    Supply voltage: min 0.6, current 24.5, max 25.0, under voltage events: 0, over voltage events: 0
    Driver 0: standstill
    Driver 1: standstill
    Driver 2: standstill
    Driver 3: standstill
    Driver 4: standstill
    Date/time: 2017-11-21 20:17:59
    Slowest main loop (seconds): 0.607820; fastest: 0.000042
    === Move ===
    MaxReps: 0, StepErrors: 0, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    Probe change coordinates:
    === Heat ===
    Bed heater = 0, chamber heater = -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    Code queue is empty.



  • For starters, check for typos. Right off the bat I see a few typos in your config.g file:

    on M563 you have "PO" instead of "P0"
    on m584 the M should be capitalized

    The M501 at the end of config.g is calling for the loading of config-override.g, so you'll want to post that here too.

    It also wouldn't hurt to post a diagram of how you've connected the stepper drivers to the board, and also what make/model the stepper drivers are (so active high/low can be set properly, as well as step width).


  • Banned

    kl-5056 from automation technologies. auto active high low whatever they set them selves as far as pulse goes. dir would still work 1 direction. pulse width 1.2us step+ to step+ step- to step- and so on. fully matched polarities on all connections. it worked before using the test ports the latest diagram say not to use. I removed those singal leads when I saw the update. this was a running machine. I only move to the expansion header as per instruction. now I have no machine.



  • Yes, when you were using test points, the machine needed to be configured to use drives 0-4. Now you're using drives 5-11, and need to set things up accordingly. This is done in the M569 commands, which are still set up for drives 0-4 it seems.

    I've never heard of an "auto active high low", I don't know how that would be possible - how would the stepper driver guess what a signal is supposed to mean? The product manual for the KL-5056 states that high enables the driver, low disables the driver. But in your M569 commands you have a mix of some active high, some active low.

    Have you corrected the aforementioned typos? Where do things stand now? What about the config-override.g? A wiring diagram would still be helpful, both for now and for any future troubleshooting/questions.

    I understand you're frustrated, but please see that you're trying to do something uncommon and unconventional, and therefore difficult. This is further complicated by only providing partial information. There are a lot of folks trying to help, it wouldn't hurt to show them some appreciation, too.


  • Banned

    ; Configuration file for Duet Ethernet (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Oct 23 2017 18:51:17 GMT-0400 (Eastern Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X295 Y295 Z207 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y1 Z1 S0 ; Define active high microswitches
    M558 P5 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to BLTOUCH, the axes for which it is used and the probe + travel speeds
    G31 P50 X50 Y10 Z.7 ; Set Z probe trigger value, offset and trigger height
    M557 X35:200 Y35:200 S20 ; Define mesh grid
    M557 R78

    ; tools
    M563 P0 D6:8:9 H1 F2
    G10 P0 S0 R0 X0 Y0

    ; Drives
    M569 P10 S1 R1 T2 ; Drive 10 goes forwards
    M569 P11 S1 R1 T2 ; Drive 11 goes forwards
    M569 P5 S1 R1 T2 ; Drive 5 goes forwards
    M569 P6 S1 R1 T2 ; Drive 6 goes forwards
    M569 P8 S1 R1 T2 ; Drive 8 goes forwards
    M569 P9 S1 R1 T2 ; Drive 9 goes forwards
    M584 X10 Y11 Z5 E6:8:9
    M350 X16 Y16 Z16 E16:16:16 I0 ; Configure microstepping without interpolation
    M92 X100 Y100 Z3200 E80:80:80 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X4000 Y4000 Z180 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250:250:250 ; Set accelerations (mm/s^2)
    M906 X0 Y0 Z0 E0:0:0 ; Set motor currents (mA)
    M84 S0 ; Disable motor idle current reduction

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M307 H7 A1 C1 D1
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 P kathryn printer ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    ; Miscellaneous



  • Yes, it is possible to run 12 steppers from a Duet.

    If you don't have a config-override.g, then you shouldn't be calling M501 (at the end of config.g).

    I'm asking for a wiring diagram because it is necessary to know how things are connected in order to set up config.g. I don't have any way of knowing how to set up the active high/low parameter without seeing how you've connected things, for example. If the stepper enable is not configured correctly, no motion will result.

    It looks like you still haven't fixed the typos I mentioned in the first post, nor the M569 commands. It looks like you changed the comments on the M569 commands, but not the commands themselves. The comments are ignored by firmware, they are just there as human-readable notes.

    I don't know how else to try to help when you're not following the suggested fixes. I do wish you the best with your build.


  • Banned

    i didn't run the config program the admin did


  • Banned

    that was generated for me and I on changed axis requirements


  • Banned

    pasta function pasted the wrong copy sorry



  • I took your updated config file posted above (looks like you deleted your post and posted a new version while I was posting), and can verify that the step/direction signals are being generated, see attached.

    I verified all of the axes, even though it meant taking the time to update my dev board's firmware.


  • Banned

    Ok thanks for that. I have movement on x and z only. they are on drives of different controller ends. 1 on lcd and the other expansion. z only move during homing which fails. I can jog x only. y and all three extruders are dead sticks still. now everytime I make a change to the config via web I can't reconnect. it's the same ethernet connection. I removed the enable leads to auto enable drives. that worked for enable and I have some movement. But the connection error say can't connect to firmware. I can access the web control be address but not reconnect. I have to use usb and repeteir host to send M552 S1 everytime the un plug usb, because the ethernet wont connect with usb even plug in. I am power my desktop and the printer from the same power supply so gnd is common.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.