Mixing extruder command M567 gives an error



  • I've tried the most reason firmware version 1.20beta8+1 and i still get errors, when trying to use the mix feature M567.
    I've also tried to enable with the M568 command, but it's obsolete now.

    In the GCode i sent this command:
    M567 P0 E0.951:0.033:0.020

    And here's the reply in the console:
    "Error: GCodes: Attempt to read a GCode float array that is too long: M567 P0 E0.951:0.033:0.020
    Setting mix ratios - wrong number of E drives: M567 P0 E0.951:0.033:0.020"

    To my best knowledge i've setup the tools correctly as you can see by the snip from my config.g file:

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes forwards
    M584 X0 Y2 Z1:8:9 E3:4:5 ; Apply custom drive mapping
    M350 X16 Y16 Z16:16:16 E16:16:16 I1 ; Configure microstepping without interpolation
    M92 X80 Y100 Z400 E95:95:95 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z3000 E300:300:300 ; Set maximum speeds (mm/min)
    M201 X2500 Y2500 Z250 E1200:1200:1200 ; Set accelerations (mm/s^2)
    M906 X700 Y1600 Z700:500:700 E2000:2000:2000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    M563 P2 D2 H1 ; Define tool 2
    G10 P2 X0 Y0 Z0 ; Set tool 2 axis offsets
    G10 P2 R0 S0 ; Set initial tool 2 active and standby temperatures to 0C


  • administrators

    You have declared 3 tools that each use 1 extruder (a different one in each case), but you haven't declared a mixing tools (i.e. a tool that uses more than one extruder). See https://www.duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer#Tool_definition_section.



  • As David's comments above. You might also find my blog useful - especially this post. https://somei3deas.wordpress.com/2017/01/11/using-the-diamond-hotend-with-duetwifi/ You may not have a Diamond hot end but if it's a mixing hot end then then the same principles will apply.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.