Heater fault after auto tuning



  • I have a strange issue with heater auto tuning and current stable firmware 1.19 (2017-08-14).

    Performing auto tuning for my heater with M303 H1 tunes to 200° C what is pretty similar to my default printing temperature (195°).
    The values written to config-override.g are: M307 H1 A397.5 C173.2 D2.1 S1.00 B0
    When printing with those values after some time the temperature starts fluctuating and ends with a heater fault.

    After removing the model from config-override.g and rebooting the duet the output from M307 H1 is totally different:
    M307 H1
    Heater 1 model: gain 340.0, time constant 140.0, dead time 5.5, max PWM 1.00, mode: PID
    Computed PID parameters for setpoint change: P13.4, I0.095, D51.4
    Computed PID parameters for load change: P13.4, I0.949, D51.4

    Neither in config.g nor in config-override.g any other M301/M307 entries can be found.

    What can be the cause for the temperature fluctuations with the values obtained from PID auto tuning?


  • administrators

    It appears that the dead time found by auto tuning was 2.1 seconds, which is suspiciously low. What type of hot end is it?



  • @dc42:

    It appears that the dead time found by auto tuning was 2.1 seconds, which is suspiciously low. What type of hot end is it?

    Genuine E3D V6 with supplied standard thermistor.


  • administrators

    My E3Dv6 hot end tuned a few days ago as:

    M307 H1 A557.8 C265.8 D3.9 S1.00 B0

    This one has a silicone sock fitted. Your gain and time constant will be lower without one; but the dead time should be similar.

    Try tuning it again, and if it still gives a low dead time (D parameter), increase it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.