Heater 1 fault (T0) - 2000°C

  • Hi,
    yesterday evening i have switched on the duet wifi for the first time connected to my new D-Bot core xy.
    The wifi is good connected but i see this "Heater 1 fault (T0)" with 2000°C in the heater section from the web interface:

    The thermistor is connected in T1 because i read somewhere in the wiki is preferable to have the bed connected to T0 (i don't have it yet but it is a future update)
    i don't sure on it's type because it came with a e3d clone, i think it is a 100k ntc 3950.

    and this is my config.g:

    ; CoreXY sample config file for dc42 Duet firmware by Haga. Please use with care. Some of the settings needs to be changed to work with your printer. Read the duetWiki!
    ;*** https://duet3d.com/wiki/Duet_Wifi_Wiki
    ; Communication and general
    M111 S0                             ; Debug off
    M550 PLak_D-Bot_CoreXY              ; Machine name (P + anything you like)
    M551 Preprap                        ; Machine password (used for FTP connections)
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address - If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M552 S1           					; Enable WiFi
    M587 S"TP-LINK_422E42" P"31581213"  ; Configure access point
    M586 P0 S1							; Enable HTTP
    M586 P1 S0							; Disable FTP
    M586 P2 S0							; Disable Telnet
    M555 P2                             ; Set output to look like Marlin
    ;M575 P1 B57600 S1                  ; Comms parameters for PanelDue
    ; Machine configuration
    M569 P0 S1               			; Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S1              			; Drive 1 goes forwards. (Change if motor goes wrong way. Or just turn the motor connection 180 degrees around..)
    M569 P2 S0                			; Drive 2 goes forwards
    M569 P3 S1                			; Drive 3 goes forwards
    M574 X1 Y2 Z1 S0            		; set endstop configuration (X1 is at MIN end. Y2 is at MAX end. (active low switch= S0)
    M667 S1                    			; set CoreXY mode
    M350 X16 Y16 Z16 E16 I1             ; Set 16x microstepping with interpolation
    M92 X80 Y80 Z800            		; Set axis steps/mm. Check that the printer really move as much as you tell it. Not more and not less.
    M92 E138.4:138.4            		; Set extruder steps/mm. Change this to match your extruder.  http://www.instructables.com/id/How-to-calibrate-the-Extruder-on-your-3d-Printer/?ALLSTEPS
    M906 X1000 Y1000 Z1000 E1000        ; Set motor currents (mA). Increase if motor is to weak. Lower if motor gets too hot. 800-1000 is good for most.
    M201 X1500 Y1500 Z300 E4000         ; Accelerations (mm/s^2). The acceleration, speed and jerk is a setting you can alter to try making the printer to print as nice as possible.. 
    M203 X15000 Y15000 Z300 E1500       ; Maximum speeds (mm/min)
    M566 X600 Y600 Z24 E300             ; Maximum jerk speeds mm/minute
    M208 X300 Y300 Z300            		; set axis maxima (adjust to suit your machine)
    M208 X0 Y0 Z0 S1                    ; set axis minima (adjust to make X=0 and Y=0 the edges of the bed)
    G21                                 ; Work in millimetres
    G90                                 ; Send absolute coordinates...
    M83                                 ; ...but relative extruder moves
    ; Z probe
    ;M558 P1 X0 Y0 Z1                    ; Analog Z probe, also used for homing the Z axis
    ;G31 Z2.47 P500 S1                   ; Set the probe height and threshold (put your own values here)
    ; The following M557 commands are not needed if you are using a bed.g file to perform bed compensation
    ;*** Adjust the XY coordinates in the following M557 commands to suit your build and the position of the Z probe
    ;M557 P0 X30 Y25                     ; Four... 
    ;M557 P1 X30 Y155                    ; ...probe points...
    ;M557 P2 X250 Y125                   ; ...for bed...
    ;M557 P3 X250 Y25                    ; ...levelling
    ;M557 P4 X150 Y95                    ; 5th probe point for levelling
    ; Thermistors and heaters
    M305 P1 T100000 B3950 R4700 S"Estrusore1"
    ;***Choose if you want to use the M301 or the autotune results and M307 command. Don't use both.
    M301 H1 P54 I4.2 D120  		    		;PID settings for extruder 0 (no need for M301 if using M307)
    M570 S120                				;Increase to allow extra heating time if needed
    ;***Use for autotune. Comment out M301 if you do.
    ;M307 H1 A588.5 C242.9 D6.7 B0				;Autotuen result for first nozzle
    ; Fans
    ;all fans are wired as always-on
    ;M106 P1 T45 H1	; enable thermostatic mode for fan 1 at temp 45 degrees. Fan turns on when P1(extruder 1) is above 45 degrees.
    ; Tool definition
    M563 P0 D0 H1                       ; Define tool 0
    G10 P0 S0 R0                        ; Set tool 0 operating and standby temperatures
    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0                   ; Axis compensation here
    M208 S1 Z-0.2						; set minimum Z
    M501								; Load Config-Override.g that is created using M500
    T0                                  ; select first hot end
    ```My firmware version is the: 1.19 (2017-08-14)
    Do you see some problem? i can't find any issue.
    Thank you in advance

  • My fault, I've connected the heater and thermistor to E1 instead of E0

Log in to reply