Bltouch smart setup


  • Banned

    Hello I starting working toward setting up the bltouch smart to home and probe for z. I used the info off duet 3d site. I don't seem to be able to deploy and retract the probe.; Configuration file for Duet Ethernet (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Nov 25 2017 12:15:39 GMT-0500 (Eastern Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    G31 X40 Y40 Z0 P25
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X295 Y295 Z207 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active low endstops
    M558 P5 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to switch, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X40:210 Y40:260 S20 ; Define mesh grid

    ; Drives
    M569 P5 S1 R1 T2 ; Drive 0 goes forwards
    M569 P6 S1 R1 T2 ; Drive 1 goes forwards
    M569 P7 S1 R1 T2 ; Drive 2 goes forwards
    M569 P8 S1 R0 T2 ; Drive 3 goes forwards
    M569 P9 S1 R0 T2 ; Drive 4 goes forwards
    M569 P10 S1 R0 T2 ; Drive 5 goes forwards
    M584 X5 Y6 Z7 E8:9:10 ; Apply custom drive mapping
    M350 X128 Y128 Z128 E128:128:128 I0 ; Configure microstepping with interpolation
    M92 X800 Y800 Z25600 E500:500:5000 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250:250:250 ; Set accelerations (mm/s^2)
    ;M906 X800 Y800 Z800 E800:800:800 ; Set motor currents (mA)
    M84 S0 ; Disable motor idle current reduction

    ; Heaters
    M307 H7 A-1 C-1 D-1
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S60 ; Set temperature limit for heater 0 to 60C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Tools
    M563 P0 D0:1:2 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M568 P0 S1 ; Enable mixing for tool 0
    M567 P0 E0.33:0.33:0.34 ; Set mixing ratios for tool 0

    ; Network
    M550 PMy printer ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P192.168.2.9 S1 ; Enable network and set IP address
    M553 P255.255.255.0 ; Set netmask
    M554 P192.168.1.254 ; Set gateway
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S1 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

    ; deployprobe.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Nov 25 2017 12:15:39 GMT-0500 (Eastern Standard Time)

    M280 P7 S10 I1

    ; retractprobe.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Nov 25 2017 12:15:39 GMT-0500 (Eastern Standard Time)

    M280 P7 S90 I1


  • administrators

    I didn't spot anything in your config.g that would explain the problem. How have you connected the BLTouch to the Duet?


Log in to reply