Deadtime frequency adjustment?



  • Is there a way to adjust deadtime mode's frequency? I have a heated enclosure set up and I want to use deadtime mode to try maintaining a tighter temperature to target, but the cycle frequency is way too high for the task. Setting it to bang mode lets the temperature swing by several degrees each way and that's too much.


  • administrators

    Do you mean the PWM frequency, or something else?

    You can use the M307 command to set the heating model parameters.



  • Yes, the PWM frequency.




  • administrators

    Reducing the PWM frequency won't provide better temperature control unless you are using some device that can't handle the existing PWM frequency. We already use a low PWM frequency (10Hz) for the bed and chamber heaters so as to be compatible with all types of SSR. Try tuning the heater.



  • OK just to be clear, I was using bang mode for running enclosure so far, except for a couple tests. It intersects with a different issue I forgot to mention. I would use PWM mode but 10Hz causes the room lights to flicker. When I used Smoothie I set the frequency to 1Hz for bed and and 2Hz for enclosure it's fine for some reason.

    I do have a proper zero-crossing SSR by Crydom.


  • administrators

    If 10Hz causes the room light to flicker, I expect they will do exactly the same if you used a PWM frequency of 1Hz or 2Hz, but more slowly and perhaps less annoying.

    Currently there is no software command to change the PWM frequency for heaters, but I'll look at squeezing this into the 1.20 release. For now you would need to build the firmware yourself and change the value of constant SlowHeaterPwmFreq. The PWM frequency is currently an integer, so you would have to choose between 1Hz, 2Hz, 3Hz etc.



  • OK, thanks.

    I'm sure the same effect is going on but I did run the same heater setup at 1-2Hz with the other board and it was much less noticeable.

    I'll see if I can touch up the process settings so the temperature swing is tolerable in Bang mode for the time being.


Log in to reply