Problem with extruder



  • why is not enough filament out?
    always first 10-20mm. I have bondech extruder. have already tried others and always the same.

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    ;Heater
    M307 H3 A-1 C-1 D-1 ; Heater 3 reserved for BLTouch

    M667 S1 ; Select CoreXY mode
    M208 X0 Y-7 Z0 S1 ; Set axis minima
    M208 X295 Y289 Z400 S0 ; Set axis maxima

    ; Endstops
    ;M574 X1 Z1 S0 ; Define active low and unused microswitches (Old config with Microswitch)
    M574 Z0 S0 ; BLTouch Configuration, do NOT use Z-Switch anymore
    M574 X1 Y1 S1 ; Define active high microswitches
    ;M558 P1 X0 Y0 Z0 H5 F120 T9600 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    ;G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X40:280 Y40:280 S50 ; Define mesh grid ; Define mesh grid

    ;Lines for BLTouch

    M558 P5 X0 Y0 Z1 H5 F120 T2000
    G31 X35 Y10 Z1.54 P25

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z799 E412
    ;M92 X160 Y160 Z799 E5400 ; Set steps per mm
    ;M92 X159.5 Y160 Z799 E440 ; Set steps per mm tevo
    ;M92 X80 Y80 Z405 E830 ; Titan Aero 837 default value
    M566 X900 Y900 Z12 E40 ; E120 Set previously Set maximum instantaneous speed changes (mm/min)
    M203 X10000 Y10000 Z1200 E4800 ; Set maximum speeds (mm/min)
    M201 X700 Y700 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1300 Y1300 Z1300 E1000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    ;M305 P0 T10000 B3988 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    ;M305 P1 T10000 B3988 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    ;M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1

    M305 P0 T100000 B4500 R4700 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    ;M305 P1 R4700 C7.0600 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1

    ;M305 P2 R4700 H0 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    ;M301 H1 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 0
    ;M301 H2 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 1
    M570 S120 ; Increase to allow extra heating time if needed

    ; Tools
    M563 P0 D0 H1 F2 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PHypercube EVO ; Set machine name
    M552 S1 ; Enable network
    M552 P192.168.178.65 ; IP address (0 = use DHCP)
    M554 P192.168.1.1 ; Gateway
    M553 P255.255.255.0 ; Netmask
    M555 P2
    M587 S"SSHD-CABLE" P"SHD2492SHD249200" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    ;M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H-1; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    M106 P2 S0


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.