SD Slot problem



  • I got my Duet WiFi version 1.19 running on Duet WiFi 1.0 a couple of days ago and have been trying to get the settings right.
    first i got some wifi disconnect errors but i did not think much about id at the time, just figured i got a bad reception on my old spare tablet.
    The it just stopped mid print and the whole thing just froze. Restarted by cutting power but it would not start again.
    So after many tries i read something about disabling the wifi by putting the SD card in the computer and uncomment the command to start wifi i did that.
    After putting the SD card back i got it to work again by manually activating wifi. So i try to do the same print once more. Same problem but much earlier and i was still able to access the webpage and it said that it couldn't read the SD card. Tried the SD card in the computer and it works. But still i got a brand new SD Card and copied the config over to it. This time i had a real problem getting it to start again. but it came online for a short time. So after all this it wouldn't start and i couldn't connect trough the usb. At this point i pressed the erase button and followed the instructions to reprogram and update the firmware to 1.19.2 and yes it started again.
    Started a new print but this time with serial connected. Worked trough several tests and i desided to make a new test print, but a dry run without filament.
    After a while it stopped again but this time i was able to make a M122 command that i listed below.
    After this i have made several test prints trying to figure out whats going on and several times i have had Error reading file in the g-code console.
    Then i accidentally bumped into the table and it stopped… tried it agan and it seems as it is very sensitive to vibrations... Is there something I can do to fix this myself or do i need to replace the board?

    Edit: forgot the diagnostic*
    9:32:13M122

    === Diagnostics ===

    Used output buffers: 3 of 32 (15 max)

    === Platform ===

    RepRapFirmware for Duet WiFi version 1.19.2 running on Duet WiFi 1.0

    Board ID: 08DDM-9FAM2-LW4S4-6JTD4-3SN6R-92VMY

    Static ram used: 21176

    Dynamic ram used: 96192

    Recycled dynamic ram: 1416

    Stack ram used: 1304 current, 9096 maximum

    Never used ram: 3192

    Last reset 03:27:02 ago, cause: power up

    Last software reset reason: User, spinning module GCodes, available RAM 6972 bytes (slot 2)

    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff

    Error status: 8

    Free file entries: 10

    SD card 0 detected, interface speed: 20.0MBytes/sec

    SD card longest block write time: 0.0ms

    MCU temperature: min 40.5, current 40.6, max 41.7

    Supply voltage: min 12.2, current 12.6, max 12.8, under voltage events: 0, over voltage events: 0

    Driver 0: stalled standstill

    Driver 1: stalled standstill

    Driver 2: stalled standstill

    Driver 3: stalled standstill

    Driver 4: standstill

    Date/time: 2017-12-08 19:32:08

    Slowest main loop (seconds): 0.209961; fastest: 0.000000

    === Move ===

    MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0

    Scheduled moves: 0, completed moves: 0

    Bed compensation in use: none

    Bed probe heights: 0.000 0.000 0.000 0.000 0.000

    === Heat ===

    Bed heater = 0, chamber heater = -1

    Heater 0 is on, I-accum = 0.0

    Heater 1 is on, I-accum = 0.7

    === GCodes ===

    Segments left: 0

    Stack records: 1 allocated, 0 in use

    Movement lock held by null

    http is idle in state(s) 0

    telnet is idle in state(s) 0

    file is idle in state(s) 0

    serial is idle in state(s) 0

    aux is idle in state(s) 0

    daemon is idle in state(s) 0

    queue is idle in state(s) 0

    autopause is idle in state(s) 0

    Code queue is empty.

    Network state is running

    WiFi module is connected to access point

    WiFi firmware version 1.19

    WiFi MAC address 2c:3a:e8:0a:f7:69

    WiFi Vcc 3.07, reset reason Turned on by main processor

    WiFi flash size 4194304, free heap 39040

    WiFi IP address 192.168.1.131

    WiFi signal strength -65dBm

    Reconnections 0

    HTTP sessions: 3 of 8

    Socket states: 2 0 0 0 0 0 0 0

    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)


  • administrators

    My guess is that you have either a bad soldered joint on the back of the SD card socket, or a bent contact inside the SD card socket. Either way, replacing the SD card socket should fix it. How old is your Duet, and which country are you in?

    You can test access to the SD card by sending M21 to re-mount it.



  • Its a week old, and i live in Sweden.
    I have continued to try this morning and now it works perfekt. I will try some more before giving in, thinking it could be som dirt inside the slot


  • administrators

    I suggest you also look at the contacts on the back of the socket to see whether they all look properly soldered to the PCB, in case some of them are just resting on the PCB.



  • I have checked the soldering and it looks fine, took a a picture but i have no idea how to attach it to the thread.
    Also i removed the SD card to see if i could see anything odd inside but it locks ok from what i can se.
    Tried to start agan and it had stopped work….. pushed the SD Card in and out a couple of times and started and now it works again.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.