Pause/Resume issues in 1.20RC3…



  • I am running 1.20RC3 of DuetWiFi firmware and RC3 of DWC along with latest of WiFiServer.bin. When I Pause and then Resume, the print head resumes a layer or two higher than where it was paused. Subsequent pause/resumes lift the head higher. I repeated this several times and it happens under 1.20RC2 and 1.20RC3.


  • administrators

    I was unable to reproduce this. Are you using a tool Z offset, or is there anything else unusual about your configuration that might be relevant? Do you use babystepping?

    Please post your config.g file.



  • No tool Z offset. I do use babystepping. Here's my config:

    ; Think3DPrint3D configuration file for Mini Kossel for testing Duet WiFi

    ; Communication and general
    M111 S0 ; Debug off
    M550 PRostock x301 ; Machine name and Netbios name (can be anything you like)
    M551 Preprap ; Machine password (used for FTP)
    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address
    ;*** Wifi Networking - Turn WiFi Module On
    M552 S1

    M555 P2 ; Set output to look like Marlin
    M575 P1 B115200 S1 ; Comms parameters for PanelDue

    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Axis and motor configuration
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes backwards
    M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)

    ; Diagonal 205.920, delta radius 95.827, homed height 223.347, bed radius 104.0, X -1.246°, Y -0.106°, Z 0.000°
    ; Endstop adjustments X0.48 Y-0.39 Z-0.09, tilt X0.00% Y0.00%

    M665 L205.920 R94.327 H224.16 B105 X-1.246 Y-0.106 Z0.000 ; set delta radius, diagonal rod length, printable radius and homed height
    M666 X0.48 Y-0.39 Z-0.09 ; put your endstop adjustments here, or let auto calibration find them

    M208 S1 Z-2.00 ; set minimum Z

    M350 X128 Y128 Z128 E16 I0 ; Set 128x microstepping without interpolation
    M92 X640 Y640 Z640 ; Set axis steps/mm
    M906 X1000 Y1000 Z1000 E800 I60 ; Set motor currents (mA) and increase idle current to 60%
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min)
    M566 X1200 Y1200 Z1200 E1200 ; Maximum instant speed changes mm/minute
    M579 X1.005 Y1.035 Z1.01 ; Adjust scale of X, Y, and Z axis to calibrate printer

    ; Thermistors
    M305 P0 T100000 B3950 R4700 H30 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B3950 R4700 H30 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction

    ; Heater Model Parameters
    M307 H0 A80.7 C40.8 D1.4 S1.00 B0 ; Heated Bed
    M307 H1 A229.4 C185.6 D9.5 S1.00 B0 ; Hot End
    M307 H2 A340.0 C140.0 D5.5 S1.00 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 B0

    ; Fans
    M106 P1 H-1 ; disable thermostatic mode for fan 1

    ; Tool definitions

    M92 E98.0:98.0:98.0 ; Set extruder steps per mm
    M207 S3.50 F3000 ; Set firmware retraction

    M572 D0 S0.1 ; Set pressure advance for extruder 0
    M572 D1 S0.1 ; Set pressure advance for extruder 1
    M572 D2 S0.1 ; Set pressure advance for extruder 2

    M563 P0 D0:1:2 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M567 P0 E0.90:0.05:0.05 ; Set mixing ratios for tool 0 (90%,5%,5%)
    M563 P1 D0:1:2 H1 ; Define tool 1
    G10 P1 X0 Y0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    M567 P1 E0.05:0.90:0.05 ; Set mixing ratios for tool 1 (5%,90%,5%)
    M563 P2 D0:1:2 H1 ; Define tool 2
    G10 P2 X0 Y0 ; Set tool 2 axis offsets
    G10 P2 R0 S0 ; Set initial tool 2 active and standby temperatures to 0C
    M567 P2 E0.05:0.05:0.90 ; Set mixing ratios for tool 2 (5%,5%,90%)
    M563 P3 D0:1:2 H1 ; Define tool 3
    G10 P3 X0 Y0 ; Set tool 3 axis offsets
    G10 P3 R0 S0 ; Set initial tool 3 active and standby temperatures to 0C
    M567 P3 E0.34:0.33:0.33 ; Set mixing ratios for tool 3 (34%,33%,33%)

    T3 ; select tool 3 (evenly mixed)

    ; Z probe and compensation definition
    M558 P5 X0 Y0 Z0 H3 F200 T6000 ; Z probe is a BLTouch probe and is not used for homing any axes
    G31 X0 Y45.5 Z1.45 P50 ; Set the zprobe height and threshold (Higher value LOWER nozzle height, Lower value RAISE nozzle height)
    M307 H4 A-1 C-1 D-1 ; Disable heater 4 for BLTouch to use E3Heat PWM for servo control.
    M557 R75 S20 ; Mesh Bed Leveling

    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here


  • administrators

    Did you upgrade to 1.20RC from a firmware version earlier than 1.19? If so then the issue could be a firmware change in a previous release that required a change to the resume.g file. From the upgrade notes for version 1.19 in the whatsnew file:

    The behaviour of the R parameter in G1 commands has changed. Previously, G1 R1 with no additional parameters restored the head position for all axes to the values just prior to the last pause command, and G1 R2 with no additional parameters restored the head position for all axes to the values just prior to the last tool change. The behaviour now is that only axes that are mentioned in the G1 command have their values restored. So instead of using G1 R1 in resume.g to restore the head position, you must now use G1 R1 X0 Y0 Z0. As before, any non-zero axis parameters will be added to the saved position of that axis. This change has been made so that additional axes used as substitute X and Y axis are not automatically restored.



  • Yes, I see exactly what you are saying and no I hadn't updated my resume.g file to reflect the new G1 command. It still did not specify the X, Y, and Z axises. I have updated it now and we'll see how it goes.



  • I'm running a test print and pause/resume is working correctly now. That was the problem. Replacing the G1 R1 in resume.g with G1 R1 X0 Y0 Z0 fixed the problem. Thanks Dave!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.