Invert Z Probe not working?



  • I got my Duet Ethernet a couple days ago and haven't been able to get the inductive Z probe to work. I tried it on both the Z probe and Z endstop ports, and on the Z endstop input the light turns on and off and the "Endstop hit" parameter in the interface changes as expected. However, the probe signal is reversed, and the I1 setting doesn't seem to do anything. Here's what my Endstops section is right now:

    M574 X1 Y1 S0 ; Set active low endstops
    M558 P4 X0 Y0 Z1 I1 H5 F240 T9000; Set Z probe type to switch, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y71 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:185 Y15:205 S20 ; Define mesh grid
    
    

    Also one phase of my X driver seemed to be dead, it just shook and vibrated whenever I tried to move it. Remapping the X axis to the E1 driver worked, which is ok since I don't yet have a second extruder, but I may want to add one in the future.

    Edit: Huh I was able to fix it by adding Z to the M574 command. It's not supposed to work this way is it?


  • administrators

    Adding Z to the M574 command should not affect the reversal of the probe signal.

    Regarding your faulty X driver, please ask for your Duet to be replaced or repaired under warranty.



  • I just double checked, and can confirm that changing

    M574 X1 Y1 S0 ;
    ```to
    

    M574 X1 Y1 Z1 S0 ;

    
    Edit: Ohhh I figured it out. M558 P4 is set to use the E0 endstop, but I had the probe plugged into the Z endstop.

 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.