Cant find IP on Duet WiFi



  • Hi
    I am stranded.. I have been able to upgrade my cr-10 s4 with a duet wifi board.
    And getting the "Wifi module to idle" but when putting a M587 S"Hus9" P"xxx" command and asking with M587 I get:
    "SENDING:M587
    Remembered networks:
    HUS9 IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0"

    Dont know what I am doing wrong?!
    Am I supposed to use the wifi network provided by the Airport Extreme router (wich I dont have admin rights to) or should I invent my own just for the printer, dont understand the logic behind it…
    Any help much appreciated!



  • I did all this with just the USB connected but when turning on the main power and sending M552 S1 I finally got a valid IP adress, Yayy!! Happy times!



  • What you see in the M587 command just shows what you have set. If you didn't define an IP, GW, or NM in your M587, then it will show as 0.0.0.0 and you will see the IP that is assigned by the router when you issue M552.



  • @KeeganB
    Its a bit strange since I did assigned an M587 S"Hus9" P"xxxx" and it did return the 0.0.0.0 adress but when putting on the main power it did return a valid IP and I can connect from DWC.
    Now I have another strange behavior: I have set the current to x y and z motor currents to 800mA and the x and y axis sounds great but the dual stepper z axis dont sounds happy (vibrating a lot) tried a higher value (1000mA and 1200mA) and it sounds even worse, I then tried lower it (to 500mA) and now they are silent. Thought that since there are 2 steppers that they would sound better with a higher current but not…



  • I don't think you are fully understanding the M587 command, but it sounds like you've got it all working, so you should be good to go!


  • administrators

    The two Z motor connectors on the Duet are connected in series, not in parallel as they are on some other boards. So you should not increase the current just because there are 2 motors.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.