Please explain this..



  • Hi,

    I have upgraded from 1.17 to 1.20 on my D-WiFi.

    Im not getting Z to move to the probe point I want, it homes Z at X0 Y0 no matter what I set in homez or homeall..
    It must be reading the home point from somewhare but I cant find it…

    It mowes to this point G1 X100 Y100 F2000 and then move back and G30 runs at X0 Y0 (Please see the below for the context in homez of this move)
    Does anyone have a clue? If you do please explain what Im doing wrong..

    Below are the exact values I have

    Config.g
    M558 P1 X0 Y0 Z1 H3 F200 T5000 R0 ; smart IR Z probe, used for homing Z axis only, dive height 3mm, probe speed 200mm/min, travel speed 5000mm/min, no recovery time
    G31 P500 X0.0 Y-15.0 Z1.2 ; set threshold and offsets Z sets the hight of nozzle from table , negative value goes up.
    M557 X30:360 Y30:260 S68 ; Define mesh grid

    Homez.g
    G91 ; relative mode
    G1 Z4 F200 ; raise head 4mm to ensure it is above the Z probe trigger height
    G90 ; back to absolute mode
    G1 X100 Y100 F2000 ; put head over the centre of the bed, or wherever you want to probe
    G30 ; lower head, stop when probe triggered and set Z to trigger height



  • I have a similar setup but with piezo sensor.

    Have you tried running those individual codes through console manually in the same order as your homez?



  • Good Idea, I just did it and its when I execute G30 that it does its own stuff…
    When G30 is executed it moves X and Y back to zero before probing.
    Probing works but I cant controll it.



  • Make sure you delete deploy probe and stow probe macros from sys folder. These were new in 1.19 I think and are enabled if present.



  • Thank you that was it 🙂


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.