M200 Volumetric issue



  • I'm having an issue enabling volumetric extrusion using slic3r, I've added a M200 D1.78 as you will see below, but once the print start and I issue a M200 in the console, it says it's not enabled. If I go ahead and manually input M200 D1.78 it proceeds to take that.

    Charles

    ; generated by Slic3r 1.37.2-prusa3d-win64 on 2018-01-01 at 11:06:20

    ;

    ; external perimeters extrusion width = 0.63mm
    ; perimeters extrusion width = 0.63mm
    ; infill extrusion width = 0.63mm
    ; solid infill extrusion width = 0.63mm
    ; top infill extrusion width = 0.60mm
    ; support material extrusion width = 0.45mm
    ; first layer extrusion width = 0.63mm

    M107
    M83 ; extruder relative mode

    M572 D0 S0.05
    M207 S.5 F2400
    M104 S260 ; set extruder temp
    M140 S90 ; set bed temp
    M190 S90 ; wait for bed temp
    M109 S260 ; wait for extruder temp
    G28; home all without mesh bed level
    G1 Y-0.0 F1000.0 ; go outside print area
    G92 E0.0
    G1 X60.0 E9.0 F1000.0 ; intro line
    G1 X100.0 E12.5 F1000.0 ; intro line
    G92 E0.0
    M200 D1.78
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M83 ; use relative distances for extrusion
    ;BEFORE_LAYER_CHANGE


  • administrators

    Volumetric extrusion is enabled/disabled separately for each GCode source. So the M200 command in your start GCode should still work, even though M200 reports that volumetric extrusion for the GCode source that you send that command from (e.g. web interface) is not enabled. The reason it is done this way is so that the extrude buttons on the web interface and PanelDue are not affected by volumetric extrusion, neither are any filament change macros you write.



  • Got it. Thanks for the quick response!

    Charles


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.