End stops not working after upgrade to 1.19



  • The end stops are being triggered in Machine properties but not stopping the motors. And I am getting an error message on the IR Z probe "Insufficient axes homed for bed probing". I expect it is my bad, but cannot work it out. I tried changing the ends in M557 but no luck. Here are the home files.

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 17 2016 11:00:47 GMT+1300 (New Zealand Standard Time)

    ; Relative positioning
    G91

    ; Lift Z
    G1 Z5 F6000

    ; Move towards X and Y axis endstops (first pass)
    G1 X-305 Y-305 F1800 S1

    ; Go back a few mm
    G1 X5 Y5 F6000

    ; Move slowly to axis endstops once more (second pass)
    G1 X-305 Y-305 F360 S1

    ; Absolute positioning
    G90

    ; Go to first bed probe point and home the Z axis
    G1 X150 Y135 F6000
    G30

    ; Uncomment the following line to lift the nozzle after probing
    ;G1 Z5 F100

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 17 2016 11:00:47 GMT+1300 (New Zealand Standard Time)

    ; Lift Z relative to current position
    G91
    G1 Z5 F6000
    G90

    ; Move quickly to X axis endstop and stop there (first pass)
    G1 X-305 F1800 S1

    ; Go back a few mm
    G91
    G1 X5 F6000
    G90

    ; Move slowly to X axis endstop once more (second pass)
    G1 X-305 F360 S1

    ; Lower Z again
    G91
    G1 Z-5 F6000
    G90

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 17 2016 11:00:47 GMT+1300 (New Zealand Standard Time)

    ; Lift Z relative to current position
    G91
    G1 Z5 F6000
    G90

    ; Move quickly to Y axis endstop and stop there (first pass)
    G1 Y-305 F1800 S1

    ; Go back a few mm
    G91
    G1 Y5 F6000
    G90

    ; Move slowly to X axis endstop once more (second pass)
    G1 Y-305 F360 S1

    ; Lower Z again
    G91
    G1 Z-5 F6000
    G90

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 17 2016 11:00:47 GMT+1300 (New Zealand Standard Time)

    ; Lift Z relatively to current position
    G91
    G1 Z5 F6000

    ; Back to absolute positioning
    G90

    ; Go to first bed probe point and home the Z axis
    G1 X20 Y30 F6000
    G30

    ; Uncomment the following lines to lift Z after probing
    G91
    G1 Z5 F100
    G90


  • administrators

    Firmware 1.20 is current now. Please post your config.g file.



  • Awesome response as usual David. Will do the 1.2 upgrade. In the meantime here is config .g.

    ; Configuration file for Duet WiFi (firmware version 1.16)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 17 2016 11:00:47 GMT+1300 (New Zealand Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    M667 S1 ; Select CoreXY mode
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y300 Z350 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z0 S0 ; Define active low and unused microswitches
    M558 P1 X0 Y0 Z1 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X0 Y0 z1.76 ; Set Z probe trigger value, offset and trigger height

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S1 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z3200 E422 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z500 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1700 Y1700 Z1700 E750 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S300 ; Set maximum heater temperature to 260C
    ;M305 P0 T100000 B3950 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PMy printer ; Set machine name
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M501

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured


  • administrators

    Thanks. I didn't spot anything wrong in the config file.

    Are they optical endstops? Those sometimes leak a little, often due to the carriage not completely blocking the slot, and if they don't have built-in pullup resistors then the external LED+resistor pullups in the endstop circuits may not be sufficient, resulting in no response or a slow response. In an earlier firmware version (1.18 AFAIR) I disabled the internal endstop pullups in the microprocessor to try to resolve a separate issue; but I've re-enabled them in firmware 1.20.



  • The end stops are mechanical except for the IR probe on Z. I have upgraded to 1.2. Now the end stops in Machine properties are hitting but the Z probe has stopped hitting however the red LED on the IR probe is still activating at the right distance from the bed.



  • I should of said end stops still not stopping X and Y axis and z still getting Insufficient axes homed for bed probing error



  • Also getting an error message when connecting on WiFi "Can't open 0:/sys/oem.json to read, error code 4"


  • administrators

    @RodF:

    Also getting an error message when connecting on WiFi "Can't open 0:/sys/oem.json to read, error code 4"

    That's normal, and you can ignore that message.

    Please run M574 without parameters after a failed X or Y homing attempt and post the response here. You can reduce motor currents for now to avoid damage when homing an axis fails to stop.

    What type of switch are they: simple 2-wire microswitches (in which case, why are you using the NO contacts instead of the NC ones), or the 3-wire Makerbot type?



  • Just a thought but it's not this is it (from the upgrade notes for 1.19)….........

    Quote
    Important! If you use an IR Z probe or some other type that does not need to be deployed, delete the files sys/deployprobe and sys/retractprobe.g if they exist, because they are now called automatically. You can do this in the System Files Editor of the web interface.
    ...........end of Quote



  • Thanks for the input guys. The end stops are 3 wire Makerbot. I am also getting an error on the bed heater.
    Error: Temperature reading fault on heater 0: unknown temperature sensor channel
    M574 reports Endstop configuration: X:low end unknown type Y: low end unknown type Z: none,



  • Decided I had nothing to lose and redid the configuration with the RRF configuration tool. This has sorted out all my problems. Thanks for your time David.


  • administrators

    I'm sorry I was a little slow in responding. The M574 "unknown type" report was caused by a firmware bug, it should have said "active low switch". This will be fixed i release 1.20.1. The heater 0 problem was caused because you didn't have a M305 command for heater 0 in config.g.



  • Thanks again. Happily printing now.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.