Heater 1 and Fan1 Stopped Working



  • Need some help in fixing this please?

    Whilst working on my Duet powered off and using Simplify3D terminal (powered by the USB cable) when I disconnected the wiring and went back to Vin and wifi:

    1. Fan1 stayed on after the Duet had booted. I cant get it to respond to M106, it just spins. I have mapped P4 from the Duex in the meantime and it responds to M106 correctly.

    2. Also the heater 1 has stopped working. If I G10 P0 S200 there is no change in temp and the override kicks in (Error: Heating fault on heater 1, temperature rising much more slowly than the expected 1.7°C/sec). Multimeter across Heater E0 block shows 0V before I get the error message.

    As there are no M307s for the stock heater, I assume this is in the firmware which means I cant assign a heater output from the Duex5?

    I have no idea what caused the issue at this point..


  • administrators

    Regarding #1, remember that fan 1 defaults to thermostatic mode. To control it manually, you need to send M106 P1 H-1 to disable that first.

    Regarding #2, before it reports a heater fault, does the E0 heater led light up when you turn the heater on? Are you getting normal room temperature readings for heater 1, and do they increase when you warm the heater block with your fingers?



  • Hi David,

    Tried
    10:30:42 PM M106 P1 S0
    10:30:18 PM M106 P1 H-1

    Fan still runs, also commented it out of the config.g, still no luck.

    I am using PT100 and the temps reflect room temperature and I can heat it up externally and it reflects correctly, so sensor is working fine. E0 heater light does not light up when I trigger the heater.


  • administrators

    In that case it sounds like the fan mosfet has failed short circuit, and the heater mosfet or its driver has also failed. It seems odd that they seem to have failed together. Did you move any of the stepper motors by hand at high speed while the power was off?



  • Not that I can think of… I removed the bed plate and flipped it over (PEI one) (found the source of my height callibration issue, bed is .5mm dipped in centre where Z homes, as opposed to where lead screws are) and calibrated mesh.



  • Any thoughts on this part please Dave?

    "As there are no M307s for the stock heater, I assume this is in the firmware which means I cant assign a heater output from the Duex5?"


  • administrators

    There are default M307 parameters in the firmware for all the heaters, which are used if you do not provide M307 commands. The default values used depend on whether the heater is configured as a bed/chamber heater, or not.

    Does this answer your question?



  • If that means I can map my heater 4 from duex5 and assign it to T0 using M307, then yes, thanks Dave will try it tonight!!


  • administrators

    If your board is still under warranty and there is nothing to indicate that you damaged it, you can ask for it to be repaired or replaced.



  • It worked thanks Dave!! The M305 had me stumped until I realised the P is substituted for H!

    M307 H3 A340 C140 D5.5 I0 V0 S1.0
    M301 H3 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 0
    M563 P0 D0 H3 X0 F0 ; Define tool 0 to use extruder drive 0 and heater 3
    M305 P3 X200; Put your own H and/or L values here to set the first nozzle thermistor ADC correction



  • Unfortunately its one of your first V1 board so no warranty… but I will use as is for now with remapped fan and heater


  • administrators

    If you are in the US you can ask Dieter (forum user W3DRK) to give you a price for repairing it.



  • Hi David….

    Was investigating a new issue where the bed temperature doesn't rise with the heat of the bed and noticed the MCU temp is running way too high... can this be causing the issue? Th machine is just idling, no printing and the temp was touching 115 degrees? From M122...

    MCU temperature: min 99.1, current 99.2, max 115.8



  • Supply voltage looks ok…?

    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (8 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.20 running on Duet WiFi 1.0 + DueX5
    Board ID: 08DAM-999TL-MQ4S4-6J1FG-3SD6S-TPGRY
    Static ram used: 15448
    Dynamic ram used: 99416
    Recycled dynamic ram: 3920
    Stack ram used: 1392 current, 4504 maximum
    Never used ram: 7784
    Last reset 00:05:29 ago, cause: software
    Last software reset at 2018-01-06 14:37, reason: User, spinning module GCodes, available RAM 7784 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0441f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 99.1, current 99.2, max 115.8
    Supply voltage: min 24.8, current 25.0, max 25.3, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Driver 5: standstill, SG min/max not available
    Driver 6: standstill, SG min/max not available
    Driver 7: standstill, SG min/max not available
    Driver 8: standstill, SG min/max not available
    Driver 9: standstill, SG min/max not available
    Expansion motor(s) stall indication: no
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 1314881303
    Slowest main loop (seconds): 0.014140; fastest: 0.000045
    === Move ===
    MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: mesh
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    Heater 3 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.20
    WiFi MAC address 60:01:94:09:ba:08
    WiFi Vcc 3.36, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 17288
    WiFi IP address 192.168.1.5
    WiFi signal strength -56dBm, reconnections 0, sleep mode modem
    HTTP sessions: 1 of 8
    Socket states: 2 0 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)
    2:42:53 PMMessage Log cleared!


  • administrators

    Is the MCU really running that hot? If so, something is wrong. If not, perhaps you have a bad M912 command in config.g.

    The voltage reading looks a little high, but if the 3.3V rail voltage is low that will cause an artificially high reading, because the 3.3V rail is the voltage reference when the MCU measures VIN.



  • Just checked wit IR thermometer… around 32 degrees on the sticker on top of the chip....? I have no M912 in config.g....

    Also if I unplug the bed thermistor... temp still shws 28 degrees.... I am plagues by wierdness 🙂

    How do I measure 3.3V rail?



  • 3.225V on Duex 5 GPIO pins…



  • 3.222 across pin 1 and 2 on Con_LCD connector on Duet Wifi



  • MCU at 41.1C now using external thermometer


  • administrators

    Send M912 with no parameters, to check that no CPU temperature calibration is being applied. AFAIR, before calibration the MCU temperature on the ATSAM4E on the generation 2 Duets should be within 14C of the correct value.

    The voltage reading on the 3.3V rail looks too low, it should be with 2% of 3.3V. Assuming your multimeter is accurate, I suspect either too much load on the 3.3V rail (in which case the 3.3V regulator IC U2 will be getting hot), or the 5V rail is at less than 4V.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.