Updating Firmware



  • Been using the printer a bit recently after months of not touching it, and see I'm miles out of date with firmware etc.

    Here's where I'm at:

    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.18.1 (2017-04-09)
    WiFi Server Version: 1.03 (ch fork)
    Web Interface Version: 1.15a

    I see I need to update the DWC before I get into the firmware, and have tried to upload via the DWC (which I'm sure has worked before) with no success.

    As has been previously demonstrated, I'm almost computer illiterate other than day to day use.

    So starting here, https://github.com/dc42/RepRapFirmware/releases, I've downloaded the DuetWebControl.zip file and unzipped it into a folder I created on my desktop "DuetWebControl.bin", which I tried to upload via the DWC. When I selected this folder it opened it, so I selected all the contents and clicked open. On the paneldue it showed "updating firmware" and "update complete", but I'm still on the same version.

    Can someone tell me in plain english where I went wrong please?



  • Which version did you download? You may have to go to 1.19 before 1.20, and there was specific instructions on the wiki for that step. 1.19 to 1.20 was easier after.



  • So in trying to load the new DWC firmware onto the SD card with it installed in my computer it seems I may have killed it.

    The name of my printer on the Paneldue is now back to "My Duet", all controls are unresponsive and I have no connection to the portal.

    Can I go through the installation process again, or do I need a new SD card? I'm actually up for buying a new card with the latest version on it, as I understand it is easier/simpler to update now.

    Can I have some assistance please, as I was just getting set to do some paying work.


  • administrators

    It sound to me that the config.g SD card isn't being read from the SD card. You can send M21 from PanelDue to see if the SD card is readable at all. If it is, send M503 to see if config.g is readable.

    If the SD card is completely unreadable, reformat it in your PC, put it back in the Duet, and try M21 again. If it's now readable, you can put files on it. If not, try a new SD card.

    This wiki page https://duet3d.com/wiki/SD_card_folder_structure includes a link to a zip file containing all the SD card files. It's currently at version 1.19, but if you get that working then the upgrade to 1.20 is straightforward.



  • Thank you David.

    I'll give that a shot.

    Cheers,

    Neil


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.