Duet3D WiFi - WiFi Module Range Issue



  • Hey Guys,

    I recently received my Duet3D WiFi to replace the board in my CR-10 printer. Unfortunately, it would not pickup my wireless access point from 12 ft away.. but would from a hotspot on my phone from less than 1 ft away. Having read the warnings about the wifi not working well, if at all, from a metal enclosure, such as the one the CR-10 electronics come in, I decided to make a project this weekend of moving everything to a plastic container entirely… mission successful!

    And.... unfortunately, this has not improved connectivity to my Duet3D at all. I still cannot connect to an access point with a -45 dBm signal that's about 12 ft away. (Connection time-outs.) I'm pretty bummed about undergoing this project only to be shot down by what seems like a bad/failing WiFi module/antenna. Any help that can be provided would be greatly appreciated.

    I am running the latest version of firmware and WiFi Server (as of Friday evening, anyway).

    Proof of signal strength:

    https://imgur.com/gMgmaju

    Better view of enclosure:

    https://imgur.com/yN07dDV


  • administrators

    You should be able to get a good connection with a signal strength of -45dBm. When you say you are running "latest firmware", is that latest stable firmware or latest release candidate firmware?

    Also note the point at https://duet3d.com/wiki/WiFi_disconnections_and_AJAX_timeout_errors about using a fixed channel number on your router instead of Auto. There is some evidence that channel 1 give poor results and channel 6 gives much better results.



  • Here's the M122 for my board:

    M122
    === Diagnostics ===
    Used output buffers: 1 of 32 (9 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.20 running on Duet WiFi 1.0
    Board ID: 08DGM-95BLL-N6PSS-6J1F6-3S46S-KJSRM
    Static ram used: 15448
    Dynamic ram used: 99320
    Recycled dynamic ram: 4016
    Stack ram used: 3576 current, 4608 maximum
    Never used ram: 7680
    Last reset 00:02:34 ago, cause: power up
    Last software reset details not available
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 26.3, current 26.9, max 26.9
    Supply voltage: min 12.5, current 12.5, max 12.6, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 245114542
    Slowest main loop (seconds): 0.153434; fastest: 0.000042
    === Move ===
    MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is idle
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.20
    WiFi MAC address 2c:3a:e8:0b:25:e2
    WiFi Vcc 3.36, reset reason Hardware watchdog
    WiFi flash size 4194304, free heap 21472
    HTTP sessions: 0 of 8
    Socket states: 0 0 0 0 0 0 0 0
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)
    ok

    Also, here is what I ran to configure the SSID:

    M552 S0
    ok
    M587
    Remembered networks:
    Netstorm IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0
    ok
    M588 S"Netstorm"
    ok
    M587 S"Netstorm" P"heyrobfl"
    ok
    M552 S1
    ok
    WiFi reported error: Timed out while trying to connect to Netstorm
    Wifi module is idle
    M552 S1
    ok
    WiFi reported error: Timed out while trying to connect to Netstorm
    Wifi module is idle
    Error retrieving WiFi status message
    Error retrieving WiFi status message

    The 1st attempt (M552 S1) was with my AP on CH9, then I changed it to CH6, as suggested. Unfortunately, no change.

    Picture of current WiFi Strength/CH:

    https://i.imgur.com/84zJocz.jpg


  • administrators

    You could try installing DuetWiFiServer 1.20+1, available here https://github.com/dc42/RepRapFirmware/blob/dev/EdgeRelease/DuetWiFiServer.bin (follow the link, then press Download).



  • I think I got it!

    I'm running a Linksys WRT-3200ACM with DD-WRT… and for some reason the ESP module on the Duet does not agree somehow with the DHCP functionality of it... as soon as I specified optional network parameters it worked almost immediately:

    (13:16:21.706) M588 S"Netstorm"
    (13:16:21.741) ok
    (13:17:33.321) M587 S"Netstorm" P"heyrobfl" I10.0.0.25 J10.0.0.1 N255.255.255.0
    (13:17:33.436) ok
    (13:17:39.537) M552 S1
    (13:17:39.570) ok
    (13:17:43.915) Wifi module is connected to access point Netstorm, IP address 10.0.0.25

    Thank you for the quick responses on this matter... (and maybe that should be documented in Wiki, in troubleshooting?)... Not sure if this specific issue has been observed here before... just trying to help others who may stumble on this issue. Thank you again!



  • And the struggles continue… since it showed "connected", I attempted to reach the web interface via IP.. no go. I then logged into my router interface and confirmed that there was no connected MAC/IP listed in M122 output. I have tried every combination of WiFI settings I can.. to no avail... the only setting that actually works is "Open" (no security). Something in the ESP8266 module is preventing it from negotiating security correctly. Any thoughts? I also flashed the 1.20+1 firmware, no difference. Any help would be appreciated!



  • … I have two boot partitions on my router; so I selected the other partition, which still contains Linksys default firmware.. and it is working brilliantly. DD-WRT is no more... Thank you for your help!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.