Yet another gcode question (bug?): min/max and dual extruders



  • On a dual extruder (dual nozzle) printer, assuming the nozzles are 50mm apart, I understand I can configure this with G10. For example:

    G10 P1 X50 Y0 Z0

    Assuming that, when I use M208 to set minimum and maximum axis, do I set them in terms of tool 0 or tool 1? For example, given a 50mm tool offset, if the minimum for the left tool is X-150, then for the right tool it would be X-100. Which one do I set with M208 S1? Same thing for the maximum… if the maximum for the left tool is X100, then the max for the right tool would be X100. Which one do I configure?

    The only reason this really matters is because the firmware prevents movement beyond the min or max (as configured with M208) when the axis are homed.

    What I found, using the above example, is confusion when I'd set min/max in terms of my right tool (because I use the right tool to home the axis.) So, my config contained:

    M208 X-100 Y-75 Z0 S1
    M208 X150 Y75 Z150 S0

    Then when I'd home, I'd set tool 1, use G1 S1 to move to the right endstop, and use G92 to set X to 150. Everything is good as long as I'm using tool 1. However, if I switch to tool 0, I couldn't move far to the left. It would stop 50mm before the minimum. In fact, it would stop at X-100. I'd expect it to stop at X-150 (because I'm using T0. If I'm using T1, I'd expect it to stop at X-100.)

    For now, I've worked around the problem by setting X min to -1000, and ensuring no gcode actually goes that far. I suppose an alternative solution would be to use the tool change macro's to reset the M208 settings.

    Ideally, the firmware would handle all this for me.


  • administrators

    First choose the head reference point. On my dual nozzle printer I chose a point midway between the two nozzles, but you can choose it to be one of the nozzles if you prefer.

    Now define the M208 axis limits, the tool XY offsets (G10) and the Z probe XY offsets (G31) relative to the head reference point.



  • @dc42:

    First choose the head reference point. … Now define the M208 axis limits, the tool XY offsets (G10) and the Z probe XY offsets (G31) relative to the head reference point.

    Okay, I found my problem. I was mentally using my right tool (T1) as my reference point, but when I configured things I set the offset on T1 (instead of on T0.) After moving the offset to T0, everything works.

    Thank you
    Gary


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.