Mesh Grid Compensation



  • Hi,

    So I've finally got my Delta finished but when I try to run Mesh Grid Compensation I get the following error:

    Error: G29: No valid grid defined for bed probing

    I have M557 in my config.g

    I'm running a Duet 0.6 on Firmware Version: 1.20 (2017-12-23)
    Web Interface Version: 1.20-RC3

    What am I missing?
    Paul



  • ; Configuration file for Duet 0.6 (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Dec 18 2017 11:03:47 GMT+0000 (GMT)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    ;M665 R170 L360 B150 H285 X0.0 Y0.0 Z0.0 ; Set delta radius, diagonal rod length, printable radius and homed height
    ;M666 X0.0 Y0.0 Z0.0 A0.0 B0.0 ; Put your endstop adjustments here, or let auto calibration find them
    M665 L360.000 R168.627 H280.965 B150.0 X0.548 Y0.166 Z0.000
    M666 X1.248 Y-0.617 Z-0.631 A-0.20 B-0.00

    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops
    M558 P5 X0 Y0 Z0 H5 R0.4 F1000 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P100 X0 Y0 Z-0.15 ; Set Z probe trigger value, offset and trigger height
    M557 R135 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z160 E400 ; Set steps per mm
    M566 X900 Y900 Z900 E1200 ; Set maximum instantaneous speed changes (mm/min)was E1200
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)was E1200
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)was E1000
    M906 X1000 Y1000 Z1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M305 P0 T100000 B4008 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Tools
    M563 P0 D0 H1 F0 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PKosselXL ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured



  • maybe the 0.6 doesn't have enough ram to do a grid at that density try changing the S20 in the M557 line to S40 and see if that makes any difference



  • Thanks Doug that's sorted the issue, got it running at S25


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.