Z homing without a Z probe



  • Hi everyone,

    I have recently added a new Aero extruder and have removed the inductive Z probe, I didn't use it for bed levelling as the surface is quite true.
    I now have an issue where I can't home the bed anymore using the Z endstop microswitch. When I get to the Z level section in homeall I get a prompt for manual bed levelling. I have tried M558 P0 in the config file without success.
    Any advice will be greatly appreciated.

    config.g below

    M111 S0 ; Debugging off
    M555 P2 ; Set firmware compatibility to look like Marlin
    M84 S30 ; Set idle timeout
    M667 S1 ; Select CoreXY mode

    ; Endstops
    M574 Y2 Z2 S0
    M574 X1 S1 ; Define active low and unused microswitches
    ;M558 P4 I1 X0 Y0 Z0 H5 F240 T6000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    ;G31 P200 X38 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X0:250 Y13:195 S20 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S1 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M569 P4 S0 ; Drive 4 goes backwards
    M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation

    M92 X160 Y160 Z800 E1600 ; Set steps per mm
    M201 X500 Y500 Z250 E250 ; Accelerations (mm/s^2)
    M203 X6000 Y6000 Z200 E1500 ; Maximum speeds (mm/min)
    M566 X800 Y800 Z30 E200 ; Maximum jerk speeds mm/minute
    M208 X300 Y200 Z310 ; set axis maxima (adjust to suit your machine)
    M208 X0 Y0 Z0 S1 ; set axis minima (adjust to make X=0 and Y=0 the edges of the bed)
    M906 X800 Y800 Z1500 E1000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    ;M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 X18 Y0 Z0 ; Set tool 1 axis offsets
    ;G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Network
    M550 PD-Bot ; Set machine name
    M551 P4Rahsc!2 ; Set password
    M552 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    ; Miscellaneous


  • administrators

    It sounds like your homeall.g and homez.g files are set up to home Z using the Z probe, so you need to change them. See #1 at https://duet3d.com/wiki/Common_problems_and_their_solutions (I appreciate that the symptom you have is different).



  • Nailed it!
    Cheers


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.