Start script s3d



  • Hey,
    I have a small problem with the start script in s3d
    Who can help me on this road
    1st problem he does not do bed leveling,
    and 2nd problem the fan of the extruder stays out,
    this is my strart code for s3d

    G28 X Y; Home X and Y
    G1 X200 Y200; Go to center or bed
    G29; Probe the bed and turn on compensation
    G1 X200 Y200; Go to center or bed
    G30 Z1.80; Z Probe Offset
    G92 E0; Extrution distance
    G0 X0 Y0 F1000; Go to front
    G0 Z2.50; Drop to bed
    G92 E0; zero the extruded length
    G1 Y-3.0 F1000; go outside print area
    G1 X60.0 E9.0 F1000; intro line
    G1 X150.0 E12.5 F1000; intro line
    G1 E-4.5000 F9000
    G1 Z0.266 F1002

    it may be that s3d drives the fan differently than it is in the duet,
    I like to hear what I'm doing wrong or someone can help me with start script for s3d then also my extruder fan,
    thank you in advance


  • administrators

    When you say "it does not do bed levelling", do you mean that it doesn't probe the bed? If so, have you set up the bed probing grid using M557 in config.g?

    The start code you list doesn't include any commands to control the print cooling fan. Usually, slicers leave the fan off during the first layer and turn it on at the start of the second layer; but you can configure the fan behaviour in S3D.



  • I have in the config.g
    M557 X5: 395 Y5: 395 S100; Define mesh grid
    this line,
    and my start script is G29 that he should probe the bed?
    only he does not,
    the extrder fan works between this was not a setting but a bad connection,
    the part fan that usually stands the 1st layer from this is correct

    now still to find why he did not probe the bed with the comanndo G29



  • you don't want the spaces after the colons so should be

    M557 X5:395 Y5:395 S100 however that wont probe effectively I would change the S100 to say S95.


  • administrators

    You can send M557 with no parameters to see if you have a valid grid definition.



  • i have a grid definition

    M557
    Grid: X5.0:395.0, Y5.0:395.0, radius -1.0, X spacing 95.0, Y spacing 95.0, 25 points


  • administrators

    You need to home all axes before you can use G29 bed problem. If you didn't home Z before starting to print, the Z axis will not be homed.

    There will probably be an error message advising you of this on the GCode Console page of DWC.



  • thanks,
    I see it I have changed G28 x y to G28 and it works
    now adjust the feather with the z height and then make a test print
    thank you for the assistance


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.