Y motor seems to be stuttering.



  • I have been playing around trying to get each axis to home properly. I finally got the X axis working but the Y axis stutters while moving. I will try to attach a video. Any help or ideas would be greatly appreciated. Link to video is at the bottom.

    This is my homey.g file
    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 30 2017 19:42:42 GMT-0700 (Mountain Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 ; lift Z relative to current position
    G1 S1 Y-255 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F1800 ; go back a few mm
    G1 S1 Y-255 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-5 F1800 ; lower Z again
    G90 ; absolute positioning

    and here is my homeall.g file

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Mar 04 2017 15:46:00 GMT+0100 (W. Europe Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X400 Y250 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Define active low and unused microswitches
    M558 P4 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to modulated, the axes for which it is used and the probe + travel speeds
    G31 X-43 Y0 Z0 P50 ; Set Z probe trigger value, offset and trigger height
    ;Z-offset (Z0.9). Higher value LOWER nozzle height
    ; Lower value RAISE nozzle height

    M557 X15:400 Y15:250 S68 ; Define mesh grid
    M307 H3 A-1 C-1 D-1 ; disable heater 3, which makes it available for use to control the BLTouch

    ; Drives
    M584 X0 Y1 Z2 E3
    M569 P0 S1 ; Drive 0 goes forwards - X
    M569 P1 S1 ; Drive 1 goes backwards - Y
    M569 P2 S0 ; Drive 2 goes backwards - Z
    M569 P3 S0 ; Drive 3 goes forwards - Extruder

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation 16
    M92 X160 Y160 Z1600 E800 ; Set steps per mm 16
    M566 X600 Y600 Z12 E120 ; Set maximum instantaneous speed changes (mm/min) - (JERK)
    M203 X6000 Y6000 Z500 E400 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E250 ; Set accelerations (mm/s^2)
    M204 P1000 T1000 ; Set Max acceleration for P=printing moves and T=travel moves
    M906 X1600 Y1600 Z900 E1000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PBlack Widow ; Set machine name
    M552 S1 ; Enable network
    M587 S"RCMP Surveillance" P"241428433" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    Here is the link for the video: https://youtu.be/r1LtBLIYYqg


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.