12V regulator on Duet Ethernet?



  • On Duet Ethernet, I'm hoping to connect one of my printer's LEDs to FAN1 with PWM so that it lights at power up. I'd like to ask for help with the following issues …

    Currently the LED just blips bright at power up but requires M106 P1 Sxxx in order to turn back on. According to documentation, FAN1defaults to active at power up if I understand correctly. Is there someplace in one of the system files where I need to place the M106 P1 Sxxx so that the LED remains lit on its own?

    @dc42:

    Use one of the fan outputs on the DueX5, or 3 of them if it is an RGB LED panel. If you are powering the DueX5 from 12V, set the V_FAN jumper on the DueX5 to the VIN position. If you are powering the DueX5 from 24V, use the 12V setting and enable the on-board 12V regulator.

    I'm using a 24V PSU, does the Duet Ethernet also have an on-board 12V regulator? I see the jumper on the DueX5 wiring diagram but it seems not to be present on the Duet Ethernet.

    Thanks!

    • Michael

  • administrators

    1. Fan1 defaults to thermostatic mode. So you need to disable that if you use Fan 1 to drive the LEDs. You can use M106 H-1 S1 near the start of config.g.

    2. The Duet Wifi/Ethernet do not have a 12V regulator on board, only the DueX2 and DueX5 have that.



  • Thank you David, I just wanted to be sure that I wasn't missing something on the Duet wiring diagram.

    I see that my firmware had
    ; Disable Fan 1 thermostatic mode
    M106 P1 H-1
    present by default.

    I've been trying power up with the addition of the S1 parameter but am still only getting a blip on the LED.


  • administrators

    Odd, adding S1 ought to work. Send M106 P1 with no other parameters to see what settings are in effect for fan 1.



  • I get

    M106 P1
    Fan1 frequency: 250Hz, speed: 0%, min: 10%, blip: 0.10, inverted: no

    Is it the "speed: 0%" which is the problem?

    This is my current entry in config.g:

    ; Disable Fan 1 thermostatic mode
    M106 P1 H-1 S1


  • administrators

    Are you sure there isn't a second M106 P1 command in config.g?



  • Indeed there was! I'm sorry, I had skimmed the file looking for another but missed it – just a few sections below the first, I see

    ; Fans
    M106 P1 S-1

    All fixed, thanks again for your help and attention David!

    • Michael

Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.