DC42 IR probe not working correctly



  • I finally have the DC42s Ir sensor mounted and reading on my custom delta printer, but im running into a issue. No matter what I do in terms of bed reflection, I continue to get a P reading of 1000+. I have installed it in right configurations for my Duet Wifi board. Previously I was using my Onyx heat bed,(which is already a shinny black color) with a sheet of boro on top, and my readings were continuously 1000+. I then added black construction paper to the underside of the glass plate, and even still I had a reading of 1000+. I then tried a blank sheet of white paper, Directly underneath the sensor board and still had a reading of 1000+. The only time i was able to get it to rear under 1000 was if i used card board, but im not sure why. I thought the reflection of the lights and tiles flooring of my room, was contaminating the l light sensors of the board. But even after I turned off all the light in my room, I was still having the same issue. Anybody have any ideas whats going on?


  • administrators

    Is the LED on the sensor working correctly? It should flash 4 times a few seconds after power up, and after that it should light up only when the sensor is triggered.



  • It flashes 2 times after its powered on, if im not mistaken. Then it'll only flash when its triggered, but when its triggered its continuously reads a signal 1000 + or- 4. I cant get it to trigger itself at the 350-400 range like its say in the installation guide you recommend.


  • administrators

    It sounds to me that you don't have it wired correctly. See https://duet3d.com/wiki/Connecting_a_Z_probe#Mini_differential_IR_sensor_by_dc42.



  • I didn't see the part where I needed to change M558 command. Ill try that and report back with what I find. Thanks for the help!



  • Hi eddygara,

    did you solve your issue here ?
    You need to look in the config.g file for the M558 command David is referring to.

    I just checked on my printer and the probe is LED is blinking two time when set to P0
    You should use
    M558 P1
    to have it correctly working with all features.

    One think I noticed on my printer, if you have +5 V VSB (standby power) connected to your Duet Wifi, you need to power cylce the PSU to see the probe blinking.

    Regards
    Pumlux



  • @Pumlux:

    Hi eddygara,

    did you solve your issue here ?
    You need to look in the config.g file for the M558 command David is referring to.

    I just checked on my printer and the probe is LED is blinking two time when set to P0
    You should use
    M558 P1
    to have it correctly working with all features.

    One think I noticed on my printer, if you have +5 V VSB (standby power) connected to your Duet Wifi, you need to power cylce the PSU to see the probe blinking.

    Regards
    Pumlux

    Yeah I was able to find the solution, it was wired incorrectly. The new issue im working on is calibrating the trigger height. When setting up the IR sensor like in the instruction provide. Once I start my prints the hot end starts way above where it should. Not only this but if i ever define a new Z axis too 0, the new recording wont save. I have to enter the exact z height, in my config file, but probing the head with a sheet a paper, then homing and entering the number given.



  • Hi eddygara,

    did you solve this issue already ?

    I had been fighting for z-axis calibration for a long time and can confirm this is very important for the printing.
    The first layer must be best on the hole print.

    Some of the outcome that I find during my calibration cycles so far.

    1. You need to be sure that the probe mount is good enough to have a reoccuring precission.
      I had printed my first z-Probe mount myself and that was always changing the hight of the IR_sensor for some 1/100 to 1/10 mm resulting in the printnozzle being much to high. I change to a metal mount and this has solved this chaning z-Probe height issues

    2. You need adjust the z height parameter in the G31 command in the config and after saving the config.g you need to power cycle the duet (if not already suggested by the firmware anyway) Please be sure, when using a sheet of paper the z value of the nozzle is not 0 but t he thickness of the paper ! You may see that the printed surface is still not close, than reduce the nozzle height in som 1/100 mm steps.
      Note I : The height of the nozzle is only set for this one point you adjusted, this is sufficient if your print bed is 100% flat and horizontal. If this is not the case, you need to calibrate the bed or use autocalibration ( that is another story)

    Note II : If the nozzle is too high, you need to increase the value for the Z parameter of G31, telling the firmware at the triggered height position the nozzle is a bit higher over the bed. Than the firmware knows the bed is a bit deeper under the nozzle.

    Normally if you have set the G31 Z height correctly ,the nozzle height should be always set correctly and reproducable.
    You may want to heat up the nozzle and the bed to the temperature you use normaly, as there might be some heat elongation, depending on the materials you have used.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.