Extruder stepper making sound (solved :)



  • I have been thinking of moving my titan extruder when I noticed the mount had a crack. I took it off and fixed it with superglue and put it back together. While getting it ready to print spare part, I noticed that the wheel of the extruder got stuck and so I dismounted and adjusted it and put it back together. After testing it, the wheel was free to move and I started up to print again. It seems to be extruding well, but in some parts of printing I now get vibration type sounds from the stepper(possibly skipping). It seems to not hold much power when I put my finger to the wheel and will stop easily, however will rotate as needed if I just help a little.

    The extruder is of pancake type and I am running 24v on my kossel. I wonder if I 1. have ruined the driver on the duet-wifi by accidently plugging it in while on… not sure if I did this by accident, 2. do not have enough current on the motor, or the motor itself perhaps is perhaps damaged.. What are my options and how should I be testing further to check? Extruder is currently on 1A, but when checking google some people use much more current on the same pancake motor.

    My setup worked just great before this, so appreciate any assist I can get. Currently the file is printing, but seems to be underextruding as motor skips and so I will not be using print. From checking now on the print itself, extrusion per layer is very variable and very ugly... 😞



  • Hi Leif,

    Just a couple days ago I was having the same symptoms on one of my e3d Titan Aeros, also with a pancake motor. It's this motor https://www.omc-stepperonline.com/hybrid-stepper-motor/nema-17-bipolar-18deg-18ncm-255ozin-07a-29v-42x42x25mm-4-wires-17hs10-0704s.html with the current set to .7A. It hardly even gets warm at .7A and I'm sure it can do more.

    One of the bearings on the filament feed gear had failed. With the extruder apart it would squeak and bind when turning by hand. Googling "e3d Titan bearing failure" reveals this is a known problem, possibly related to a certain batch of bearings, and that e3d is reviewing their QC.

    I've also noticed that very small changes in the position of the drive gear on the motor shaft w.r.t. the filament feed gear can cause significant friction once the thing is reassembled. e3d advises that the outer surfaces of those two gears should be completely flush when assembled, and indeed that seems critical. You might want to revisit that too. In fact, after I reassembled my bad extruder with a replacement bearing, the gear wouldn't move smoothly by hand because this alignment was imperfect.

    Seems unlikely that you damaged either the controller or the motor, but a definite alternate possibility is a faulty connection in the cable for the motor. If you probe the pins at the Molex header connector (that plugs into the board) in pairs, you should get some single-digit number of ohms per motor winding. It would also be good to do this test with the extruder positioned at various points in it's travel range on the gantry, or even while you're moving it around, to look for an intermittent failure.

    ~Justine



  • 🙂 Thank you Justine for superquick answer and checkpoints… I took extruder apart again, reassembled it flush and doublechecked it all while testing it with a bit of load.. works as butter again 🙂 🙂



  • Oh cool, good! Just sitting in a long meeting with laptop in hand, haha.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.