Power cuts out when homing.



  • I am running a delta printer. Got everything wired up and for 24 hours, everything worked fine. Calibrated and did a few test prints. Went to calibrate a lil more after adjusting the bed and while uploading a different file, got an upload error. Then disconnected and refused to reconnect. Checked the printer. No power.

    Tested multiple psu's, no wires shorting to ground. Deut board on standoffs. Not running the hot end or the heat bed, yet anytime I try to home the printer, power cuts out again.

    Unplugged all steppers, and plugged just one back in. Works fine on all 3 towers. Add in a second stepper, 50/50. Sometimes it will power off, sometimes it won't (doesn't matter which combo of steppers or axis I try, all have the same 50/50 result). Add all 3 back in, 100% whether I home one axis or all, power cuts and it shuts off.

    Bought the duet I think in August and just got around to putting it in this last week.

    Steppers all getting 3.3v measured with a multimeter.

    All capacitors look fine, no burned or scorch marks.

    Any suggestions would be appreciated as it looks like it's the driver chips on them at this time 😞


  • administrators

    First thing to check is that the screws in the power input terminal block are tight.

    Does the blue LED on the Duet flicker when this problem occurs?



  • Connections for power input are nice and tight, good full contact. Blue light is solid (never flickers) during any and all activities. Now cuts out moving any single axis on it's own if more than one stepper is plugged in. Nothing else is running off the board, just steppers and endstops.


  • administrators

    If you run M122 after one of these events, what does it report for minimum, maximum and present input voltage, and number of under-voltage events?



  • Supply voltage: min 9.1, current 13.0, max 13.8, under voltage events: 35, over voltage events: 0



  • Here is the full log just in case it provides any further insight:

    Send
    Clear Log
    9:57:01 am
    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (7 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.19 running on Duet WiFi 1.0
    Board ID: 08DDM-9FAM2-LW4S4-6JTDA-3S46T-K3TBX
    Static ram used: 21176
    Dynamic ram used: 96040
    Recycled dynamic ram: 1568
    Stack ram used: 1304 current, 4840 maximum
    Never used ram: 7448
    Last reset 00:01:05 ago, cause: power up
    Last software reset reason: User, spinning module GCodes, available RAM 3232 bytes (slot 2)
    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 13.8, current 18.8, max 19.4
    Supply voltage: min 9.1, current 13.0, max 13.8, under voltage events: 35, over voltage events: 0
    Driver 0: stalled standstill
    Driver 1: stalled standstill
    Driver 2: stalled standstill
    Driver 3: standstill
    Driver 4: standstill
    Date/time: 2018-01-21 09:57:00
    Slowest main loop (seconds): 0.005901; fastest: 0.000034
    === Move ===
    MaxReps: 3, StepErrors: 0, FreeDm: 240, MinFreeDm 237, MaxWait: 4073ms, Underruns: 0, 0
    Scheduled moves: 3, completed moves: 3
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heater = 0, chamber heater = -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.19
    WiFi MAC address 60:01:94:34:39:ea
    WiFi Vcc 3.15, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 38720
    WiFi IP address 192.168.0.17
    WiFi signal strength -67dBm
    HTTP sessions: 1 of 8
    Socket states: 2 0 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)


  • administrators

    Supply voltage: min 9.1, current 13.0, max 13.8, under voltage events: 35, over voltage events: 0

    That's the problem. The input voltage is regularly dropping below the minimum 9.5V. Possibly causes include:

    1. Bad connection between the PSU output and the VIN terminal block;

    2. Excessive load on the PSU, e.g. bed heater turned on and the PSU doesn't have the capacity to handle it;

    3. PSU has a 115V/230VAC input voltage selector switch, and your mains is 115V but you have it set to 230V;

    4. Faulty PSU.



  • 2 different psu's both running 115v. I could understand one being faulty, but 2 is doubtful.

    Only parts running are the steppers, endstops, and one always on fan. I kept the hotend and heatbed off when this happens.

    Main power is nice and tight in the terminal block, however, ther terminal block itself has a bit of slop/rotation where it connects to the board itself. When tightening or loosening, it tends to slightly twist whichever direction you're going, so this might be where the issue is then. I'll flip it over and examine the solder points on the bottom of the main power terminal after work



  • Thanks so much dc42! It was apparently two fault psu's. Bought a 24v psu and the original issue has been resolved. In my haste I failed to realize I needed a 24v heater cartridge for my hot end now haha glad the previous issue is resolved, on toward more waiting now lol


  • administrators

    I'm glad you solved it. One possible cause I didn't mention was the wires between the PSU and the Duet being too thin, so that when the bed heater turns on the voltage drop in those wires is too great.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.