GPIO/Fan outputs



  • I have been working with the GPIO pins trying to set a few pins high/low to trigger external processes. I had them connected to an Arduino mini, and they worked briefly, but no longer respond to the M42 command. I have tried switching to the fan outputs, thinking I may have burned out the GPIO pins, but even these are not switching. (They will not even turn on a fan with either the M106 or M42 after disabling the fan behavior, I understand that they are low side switching outputs).

    Am I doing something wrong, or is there a bug that I am not aware of with the GPIO pins, and fan outputs?


  • administrators

    Are you referring to the gpio outputs on the DueX expansion boards? If so, does the Duet recognise that the DueX board is present when you start the Duet, as indicated in the Settings General page of DWC?



  • I am using the Duet Wifi with the Duex5, I don't see anything in the web interface that indicates there is a Duex5 connected, should there be?

    I have been using motor controllers and heaters off of the Duex5 for some time now, and haven't had any issues with it, I don't recall there being any indicator that it was connected.


  • administrators

    If a DueX5 is connected, then the Electronics description on the Settings General page should mention it, close to where it displays the firmware version.



  • I don't see any indicator that there is a Duex5 connected in the web interface, I tested with another Duex5 to see what the problem is, and the other Duex5 worked fine - as in it shows up in the web interface.

    What's weird is that I'm using heaters, the PT100 breakout board, a stepper motor driver on the Duex5, but these things all have dedicated pins on the Duet Wifi expansion header. The only things that seem to not work are the external triggers (off the endstop inputs), the fans and the GPIO pins.

    How is that detection handled? It seems to be a hardware failure somewhere since the firmware is still capable of detecting the expansion boards (just not the one I'm working with right now). What limitations does this impose if the firmware does not detect the expansion boards?


  • administrators

    If the firmware doesn't detect a DueX board, then the heaters on the DueX will still work but the stepper motors, fans, endstop inputs and GPIO pins on the DueX won't work.

    Failure to detect the DueX board probably means that the SX1509B chip is blown, assuming that the same 50-way cable with with another DueX5. The chip can be replaced using a hot air rework station, although it's tricky because it has a leadless package. User W3DRK can replace them in the US and I can replace them in the UK.



  • That's got to be it, thanks for your help!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.