How i get my z probe working?



  • Hi, i am sorry that will buffer you again with my questions…but after 3 days i am out of ideas

    I have an PNP Inductive sensor, the sensor is so far right connected, and the web interface tells me an z probe value of 1000 if triggered, 0 if not.
    The sensor out is connected with Zprobe in on my Duet Wifi board.
    FW is 1.19.2
    What are the right parameters in my config.g that i get a mesh leveling?
    Please help!

    Here my config

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Jul 11 2017 12:04:22 GMT+0200

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X472 Y555 Z375 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Define active low and unused microswitches
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P5 Z1 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P1000 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:457 Y15:540 S25 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S0 ; Drive 5 goes backwards
    M569 P6 S1 ; Drive 6 goes forwards
    M569 P7 S0 ; Drive 7 goes backwards
    M569 P8 S0 ; Drive 8 goes backwards
    M569 P9 S0 ; Drive 9 goes backwards
    M558 P5 X0 Y0 Z0
    M584 X0:9 Y7:8 Z5:2 E3 ; Apply custom drive mapping
    M350 X32 Y32 Z32 I0 ; Configure microstepping without interpolation
    M350 E32 I0 ; Configure microstepping without interpolation
    M92 X160.06 Y160.06 Z1615.51 E198.77 ; Set steps per mm
    M566 X900 Y900 Z120 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z2000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z40 E250 ; Set accelerations (mm/s^2)

    M906 X800 Y800 Z1000 E1000 I0 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S300 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B3950 C0 R4700 L0 H0 ; Set thermistor + ADC parameters for heater 1
    M305 P0 R4700 T100000 B3950 ; set HBP thermistor parameters
    M301 H1 P10 I0.2 D50 T0.3 S0.5
    M303 H1 P0.4 S270 ; tune heater 1 using 40% PWM, quit if temperature exceeds 240C
    ;M570 S150 ; Set maximum heating time to 150s

    ; Tools
    M563 P0 D0 H1 F0 ; tool 0 uses extruder drive 3 and heater 1 , Lüfter 0
    G10 P0 S0 R0 X0 Y0 ; set tool 0 temperatures and offsets
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S1 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PCube Maxima ; Set machine name
    M552 S1 ; Enable network
    M587 S"spirit" P"amiga512$" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

    Thanks for your help
    Maurice


  • administrators

    See https://duet3d.com/wiki/Test_and_calibrate_the_Z_probe to calibrate the Z probe trigger height, and https://duet3d.com/wiki/Using_mesh_bed_compensation to set up mesh bed compensation.



  • Hi, tried that… the G30 S-1, worked not like discribed
    Like the manual said, i moved my nozzle into middle (to X220 Y250) of my bed. Drop my nozzle til 0,05mm and send the G92 Z0...
    than G1 Z5
    So far so good
    if i send the G30 S-1 my head drives to X25 Y93 Z40, than to X-5 Y93, but he moves only a couple mm, than he zeros to X0 Y0 Z35
    than he raised the bed and tells me the triggerheight...0.225mm as example, i get no consitent values
    than he goes to X-59 Y66 Z40 and zeros again to X0 Y0 Z35
    after homing in the first round he crashed because of the X-59 in my x endstop....

    Can somebody tell me what is going on with my printer????
    Please help me...
    Thx Maurice



  • Do you still have deploy and retract folders? If so, delete them.



  • Thanks, this was the answer.
    After delete them two files the G30 S-1 produces values as expected.
    thanks alot
    Maurice


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.