Configuring the chamber heater with a higher dead-time



  • Hi!

    I'm trying to set-up a 3D printer with a heated chamber. Since it is heating very slowly, it needs quite a bit of time before increasing temperature.

    However, with the maximum setting for M307 dead-time (60 secs), I'm not able to make it work, the heater doesn't heat quickly enough.

    Check the code below:

    ; Chamber
    M141 H2                                   ; Assign chamber heater to heater 0
    M143 H2 S100                              ; Set temperature limit for heater 0 to 120C
    M307 H2 A50 D60 B1                        ; use bang-bang control for the chamber heater with 60 seconds dead time
    M305 P2 T97968 B4630 C9.486166e-8 R4700   ; Set thermistor + ADC parameters for chamber
    
    

    Is there a way to either increase the dead-time or disable the protection for this heater?

    Regards,
    Phil


  • administrators

    What happens if you try to set a dead time longer than 60 seconds?



  • I gave up trying to monitor chamber temp and controlling the heater by chamber temperature. Instead I've fitted the thermistor to the heater heatsink itself, and just set the heater to a temperature which will give me the 40 deg C chamber temp I want.

    Since it rarely varies, if I set the heater to 80 deg C my chamber reaches 40 deg C, given that the bed temp is a constant for abs printing also.



  • @dc42:

    What happens if you try to set a dead time longer than 60 seconds?

    When I send:

    M307 H2 D60
    
    ```Everything looks good, and sending M307 H2 shows that the dead time is set to 60 seconds.
    
    Sending:
    

    M307 H2 D120

    
    Same does for 61\. I believe the max configurable is currently 60, but a higher value could solve our heating problem.
    
    Thanks for your support!

  • administrators

    You need to increase the time constant too because the firmware checks that the time constant is at least twice the dead time.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.