Help with IR probe on Anycubic Kossel



  • Hi everyone

    I'm new to this forum having recently bought a Duet3d board and IR probe for my Anycubic Kossel (after burning out their motherboard).

    The Duet3d is all fully installed and working well but I just can't get the bed level. I have the Duet3d IR probe installed and it is working too.

    But when I try to level the bed it's not generating accurate results.

    This has been my process:

    • First I've zeroed the bed correctly (for my printer I have used M665 R105.6 L215 B85 H332.8 in the config.g file). This is accurate to just grip a piece of paper.

    • I have run a single probe (G30 s-1) and found the right Z height to put in my G31 command in config.g (https://www.duet3d.com/wiki/Setting_up_automatic_probing_of_the_print_bed)

    • I have set the Z probe and trigger height (G31 P500 X10 Y20 Z4.17)

    • I altered the bed.g file using this calculator (http://escher3d.com/pages/wizards/wizardbed.php). I had to set the radius to 85 for the Anycubic so it didn't hit the margins of the bed.

    • Run auto calibration (G31)

    Now when I do a bed levelling test print (circle) it is clearly off as one side is higher than the other.

    I thought it may be an offset problem with the IR probe so I tried to fix this by setting H parameters in the bed.g file for every single probe point but this didn't work either. Followed the instructions on the wiki

    Ironically when I clear all the bed levelling and run the test print this is closer to level than after doing the auto calibration. But still not good enough to print.

    I had a feeling that this had something to do with the offset of the IR probe so I fixed it to the hot end (without heating) and ran a calibration but again it didn't level.

    Any assistance greatly appreciated.

    I'd be happy even to be able to manually level at this stage so I can just start printing.

    Finn


  • administrators

    Getting one side higher than the other after calibration is usually cause by the effector tilting as it moves in the XY plane, which in conjunction with the XY offset of the probe from the nozzle causes an apparent change in trigger height. Using the appropriate H parameters in the bed.g file to compensate for the variation in trigger height should get round this, assuming you entered the H parameters with the correct sign.

    If you want to calibrate manually, change your M558 command to use P0 X0 Y0 and then run auto calibration. The web interface will prompt you to jog the nozzle down to the bed (e.g. just gripping a sheet of paper) at every probe point.



  • Thanks very much for this assistance. When I set M558 to P0 X0 Y0 I get the message below. It doesn't seem to be giving me an option to jog the Z coordinate. Just the X coordinate.


  • administrators

    I think your firmware version is too old for the DWC version you are using.



  • Thanks for this. I've upgraded to the new firmware and manual calibration works now. I'll try again with the IR probe and see if it makes a difference.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.