PT100 - can't setup channel on Tool, only on bed



  • Hi!
    I good finally my Duet and doing some setup. I can't get PT100 channel mapped to Tool 0, the command M305 P1 X200 makes nothing and when I run M305 P0 X200 the temperature is showed on the bed. What I am doing wrong? Attached my config.g

    [[language]]
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Feb 16 2018 16:52:18 GMT+0100 (CET)
    
    ; General preferences
    M111 S0                                   ; Debugging off
    G21                                       ; Work in millimetres
    G90                                       ; Send absolute coordinates...
    M83                                       ; ...but relative extruder moves
    M555 P2                                   ; Set firmware compatibility to look like Marlin
    ; Automatic saving after power loss is not enabled
    
    M667 S1                                   ; Select CoreXY mode
    M208 X0 Y0 Z0 S1                          ; Set axis minima
    M208 X310 Y310 Z350 S0                    ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 S1                             ; Set active high endstops
    M574 Z1 S2                                ; Set endstops controlled by probe
    M558 P0 H5 F120 T6000                     ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X10 Y0 Z2.5                      ; Set Z probe trigger value, offset and trigger height
    M557 X10:290 Y10:290 S20                  ; Define mesh grid
    
    ; Drives
    M569 P0 S1                                ; Drive 0 goes forwards
    M569 P1 S1                                ; Drive 1 goes forwards
    M569 P2 S1                                ; Drive 2 goes forwards
    M569 P3 S0                                ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1                   ; Configure microstepping with interpolation
    M92 X160 Y160 Z3200 E840                  ; Set steps per mm
    M566 X900 Y900 Z12 E120                   ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200               ; Set maximum speeds (mm/min)
    M201 X2000 Y1500 Z250 E2500               ; Set accelerations (mm/s^2)
    M906 X1600 Y1600 Z1200 E1600 I30          ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                   ; Set idle timeout
    
    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T10000 B3988 C0 R4700             ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                              ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 X200       ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200
    M143 H1 S280                              ; Set temperature limit for heater 1 to 280C
    
    ; Tools
    M563 P0 D0 H1                             ; Define tool 0
    G10 P0 X0 Y0 Z0                           ; Set tool 0 axis offsets
    G10 P0 R0 S0                              ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Network
    M550 PHypercube Evo                       ; Set machine name
    M552 S1                                   ; Enable network
    M587 S"network" P"password"              ; Configure access point. You can delete this line once connected
    M586 P0 S1                                ; Enable HTTP
    M586 P1 S0                                ; Disable FTP
    M586 P2 S0                                ; Disable Telnet
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1                  ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45                 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Custom settings are not configured
    
    ; Miscellaneous
    M501                                      ; Load saved parameters from non-volatile memory
    T0                                        ; Select first tool
    
    ```Probably I am not understanding some g-code command.


  • Oh that is strange, I changed M305 P1 T100000 B4138 C0 R4700 X200 to just M305 P1 X200 and it works now. As far I know other parameters should be ignored when X200 jest present?


  • administrators

    The R parameter is no longer ignored when using a PT100 sensor, it is the reference resistor value (default 400)



  • Hmmm maybe the RepRapFirmware Configuration Tool should change it to 400 (in the entry box) or skip it if you select RTD sensor on a heater?



  • yes I agree just ran one thru the configurator and it does indeed leave all the params in there.


  • administrators

    Thanks for pointing this out. It will be fixed soon.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.