During simulation, status report shows "P" for printing.



  • Via DWC, ask the printer to simulate a print. Gcode log shows it is simulating, printer does not move, etc.

    However, the AJAX/JSON status shows the printer is "P" printing, not "M" simulating. Please note that I obtained the idea that "M" is for simulating from a "switch/case" statement in the DWC javascript code. This may be deprecated. It certainly would be handy for the "Multi Duet" monitor.

    Gcode Log:

    [[language]]
    6:06:41 PMM37 P"DBFD_Thread Brace for 2020 - Both.gcode"
    Simulating print of file DBFD_Thread Brace for 2020 - Both.gcode
    
    

    Response from [c]http://192.168.86.100/rr_status?type=3[/c]

    [[language]]
    {"status":"P","coords":{"axesHomed":[1,1,1],"extr":[1155.3],"xyz":[7.517,-12.165,2.250]},"currentTool":0,"params":{"atxPower":0,"fanPercent":[0.00,100.00,0.00,0.00,0.00,0.00,0.00,0.00,0.00],"speedFactor":100.00,"extrFactors":[100.00],"babystep":0.000},"seq":43,"sensors":{"probeValue":1000,"fanRPM":0},"temps":{"current":[2000.0,22.6,2000.0,2000.0,2000.0,2000.0,2000.0,2000.0],"state":[0,2,0,0,0,0,0,0],"heads":{"current":[22.6],"active":[0.0],"standby":[0.0],"state":[2]},"tools":{"active":[[0.0]],"standby":[[0.0]]},"extra":[{"name":"MCU","temp":35.5}]},"time":37395.0,"currentLayer":0,"currentLayerTime":0.0,"extrRaw":[1156.0],"fractionPrinted":9.3,"firstLayerDuration":0.0,"firstLayerHeight":0.30,"printDuration":52.7,"warmUpDuration":0.0,"timesLeft":{"file":511.7,"filament":0.0,"layer":0.0}}
    
    

  • administrators

    Thanks, I'll take a look.


  • administrators

    Will be fixed in 1.21RC3.



  • Thank you!

    A very hidden thing that will make Multi monitor work much better. THANK YOU.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.