U axis is not working



  • Hello every one.

    I am using duet+duex 5 expension boards. I try to use idex configuration. So X axis working very well but when i try to print something with U axis not working. After gcode "T1" tool change to U axis(second x axis) is not working.

    All axis goes to home. Also G1 commend is work for all axis(X,Y,U,Z,). I can't solve this problem.

    Here is my configuration

    config.g
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Feb 19 2018 15:31:30 GMT+0300 (Arabic Standard Time)

    ; General preferences
    M501 ;config override
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    ; Endstops
    M557 X15:275 Y15:155 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes forwards
    M584 X0 Y1 Z2 U3 E4:5 ; Create U axis for second X carriage before we try to configure it
    M350 X128 Y128 Z128 U128 E128 I1 ; Configure microstepping with interpolation
    M92 X640 Y640 U640 Z2560 ; Set axis steps/mm
    M574 X1 Y1 Z1 U1 S1 ; Set endstop configuration (X and Y endstops at low end, U endstop at high end, active high, no Z endstop)
    M92 E1000:100 ; Set extruder steps per mm
    M566 X600 Y600 U600 Z30 E20 ; Maximum jerk speeds mm/minute
    M201 X800 Y800 U800 Z15 E1000 ; Accelerations (mm/s^2)
    M203 X15000 Y15000 U15000 Z100 E3600 ; Maximum speeds (mm/min)
    M906 X800 Y800 U800 Z800 E1000 ; Set motor currents (mA)
    M563 P0 D0 H1 F0 ; tool 0 uses extruder 0, heater 1 and fan 0
    G10 P0 X0 Y0 Z0 S0 R0 ; set tool 0 offsets and temperatures
    M563 P1 D1 H2 X3 F2 ; tool 1 uses extruder 1, heater 2, fan 2, and maps X to U
    G10 P1 X0 Y0 U500 Z0 S0 R0 ; set tool 1 offsets and temperatures
    M84 S0 ; Set idle timeout

    ; Heaters
    M305 P0 T100000 B4623 C9.264103e-8 R4193 ; Set thermistor + ADC parameters for heater 0
    M305 P1 X200 ; Set PT100 for heater 1
    M143 P1 S2800 ; Set temperature limit for heater 1 to 280C
    M305 P2 X201 ; Set PT100 for heater 2
    M143 P2 S280 ; Set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    [[ homeall.g]]
    ; Home X, Y, U simultaneously
    G91
    G1 Z4 F200 ; raise head 4mm to keep it clear of the bed
    G1 X-440 Y-440 U440 F3000 S1 ; course home X, Y and U
    G1 X4 Y4 U-4 F600 S2 ; move 4mm away from the homing switches
    G1 X-10 Y-10 U10 S1 ; fine home X, Y and U
    G90

    homex.g
    ; Home X at the low end of the axis
    G91
    G1 Z4 F200
    G1 X-240 F3000 S1
    G1 X4 F600 S2
    G1 X-10 S1
    G1 Z-4 F200
    G90

    homey.g
    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Feb 19 2018 15:31:30 GMT+0300 (Arabic Standard Time)
    G91 ; relative positioning
    G1 Z2 F6000 ; lift Z relative to current position
    G1 S1 Y-175 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000 ; go back a few mm
    G1 S1 Y-175 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-2 F6000 ; lower Z again
    G90 ; absolute positioning

    homez.g
    G91 ; relative mode
    G1 Z4 F20000 ; raise head 4mm to ensure it is above the switch trigger height
    G90 ; back to absolute mode
    G1 X0 Y0 F200000 ; put the head wherever you want it to be when you home Z (omit this line if it doesn't matter)
    G91 ; relative mode
    G1 Z-900 S1 F100000 ; move Z down until the switch triggers
    G90 ; back to absolute mode
    G92 Z0.3 ; tell the firmware that we are at Z=0.3mm

    homeu.g
    G91
    G1 Z4 F200
    G1 U240 F3000 S1
    G1 U-4 F600 S2
    G1 U10 S1
    G1 Z-4 F200
    G90

    tfree0.g
    M83 ; relative extruder movement
    G1 E-2 F3600 ; retract 2mm
    M106 S0 ; turn off our print cooling fan
    G91 ; relative axis movement
    G1 Z3 F500 ; up 3mm
    G90 ; absolute axis movement
    G1 S1 X-10 F6000 ; park the X carriage at -48mm

    tfree1.g
    M83 ; relative extruder movement
    G1 E-2 F3600 ; retract 2mm
    M106 S0 ; turn off our print cooling fan
    G91 ; relative axis movement
    G1 Z3 F500 ; up 3mm
    G90 ; absolute axis movement
    G1 S1 U178 F6000 ; park the U carriage at +248mm

    tfree2.g
    M83 ; relative extruder movement
    G1 E-2 F3600 ; retract 2mm
    M106 S0 ; turn off our print cooling fan
    G91 ; relative axis movement
    G1 Z3 F500 ; up 3mm
    G90 ; absolute axis movement
    G28 X U ; home the X and U carriages

    tpost0.g
    M106 R2 ; restore print cooling fan speed
    M116 P0 ; wait for tool 0 heaters to reach operating temperature
    M83 ; relative extruder movement
    G1 E2 F3600 ; extrude 2mm

    tpost1.g
    M106 R2 ; restore print cooling fan speed
    M116 P1 ; wait for tool 1 heaters to reach operating temperature
    M83 ; relative extruder movement
    G1 E2 F3600 ; extrude 2mm

    tpost2.g
    M106 R2 ; restore print cooling fan speed
    M116 P2 ; wait for tool 2 heaters to reach operating temperature
    M83 ; relative extruder movement
    M567 P2 E1:1 ; set tool mix ratio
    G1 E2 F3600 ; extrude 2mm from both extruders

    tpre0.g
    ; tpre0.g
    ; called before tool 0 is selected
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Feb 19 2018 15:31:30 GMT+0300 (Arabic Standard Time)

    Is there something i am missing?



  • For example on my gcode. It works very well until T1 command. After T1 comment U axis not start to working.

    G1 X73.629 Y94.535 E0.9055
    G1 X74.564 Y95.427 E0.9217
    G1 X75.581 Y96.226 E0.9379
    G1 X76.668 Y96.925 E0.9540
    G1 X77.817 Y97.518 E0.9702
    G1 X79.017 Y97.998 E0.9864
    G1 X80.258 Y98.362 E1.0026
    G1 X81.527 Y98.607 E1.0187
    G1 X82.814 Y98.730 E1.0349
    G1 X84.106 Y98.730 E1.0511
    G1 X85.393 Y98.607 E1.0672
    G92 E0
    G1 X86.663 Y98.362 E-1.7236 F1800
    G1 X87.903 Y97.998 E-3.4472
    G1 X89.103 Y97.518 E-5.1708
    G1 X90.252 Y96.925 E-6.8944
    G1 X90.950 Y96.477 E-8.0000
    G1 Z0.269 F1002
    ; process Color2
    ; layer 2, Z = 0.200
    T1
    ; tool H0.200 W0.400
    ; inner perimeter
    M204 S2000
    G1 X98.625 Y104.156 F12000
    G1 Z0.199 F1002
    G92 E0
    G1 X68.501 Y104.161 E0.3768 F1881
    G1 X67.942 Y104.124 E0.3838
    G1 X67.233 Y103.962 E0.3929


  • administrators

    Issues I can see in your config.g file:

    1. You have no M208 commands to specify the axis limits and homing positions;

    2. You have a tool offset of 500mm specified for the U axis in your G10 P1 command.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.