G31 Z height offset not working (Mini IR Sensor)



  • When using
    G31 X-14 Y0 Z0.075 P500
    in config.g the Z height offset has no effect

    What i tried:

    • M208 to set min Z to -0.2 -> no effect (M208 S1 Z-0.2)
    • Put G31 X-14 Y0 Z0.075 P500 in the gcode console -> no effect
    • Using negative values to see if it just is a problem with "negative Z" (G31 X-14 Y0 Z-2 P500) -> no effect

    Workaround: Babystepping
    M290 S-0.075
    (can be put in config.g, so its the default after restart)



  • How do you use the probe (what command do you use to level/calibrate after setting the probe with [c]G31[/c])?

    Negative values on Z imply that the probe will trigger /after/ the nozzle has made contact with the bed, generally a big fail. So I dont think they are used much except for specialist setups. 0.075 seems very small, generally you should have a larger gap to allow the probe to trigger without fear of hitting the bed in the process. On my system the board edge is 1.5mm above the nozzle, board triggers @ 2.7mm'ish, so my Z offset is 1.2mm (ish).

    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Calibrate_the_Z_probe_trigger_height
    edit: reword where needed


  • administrators

    @Nuvag:

    When using
    G31 X-14 Y0 Z0.075 P500
    in config.g the Z height offset has no effect

    What i tried:

    • M208 to set min Z to -0.2 -> no effect (M208 S1 Z-0.2)
    • Put G31 X-14 Y0 Z0.075 P500 in the gcode console -> no effect
    • Using negative values to see if it just is a problem with "negative Z" (G31 X-14 Y0 Z-2 P500) -> no effect

    Workaround: Babystepping
    M290 S-0.075
    (can be put in config.g, so its the default after restart)

    1. Please confirm that you are using your Z probe for Z homing.

    2. Check whether you have another G31 command in config-override.g.



  • I found the cause (in front of the monitor) 🙂

    Wasn't aware G31 is only used for auto calibration, was thrown of by "If, in later prints, you find the first layer is too thick or too thin, adjust the value in your G31 command" https://duet3d.dozuki.com/Wiki/Setting_up_automatic_probing_of_the_print_bed
    Which is only sufficient when autocalibrating afterards which i don't.

    I use auto calibration only for initial setup after changes on the printer. I found its not necessary to auto calibrate every time and it doesnt work when there is glue stick/hairspray/tape on the glass which i don't want to remove regularly.
    So i needed to increase G31 Z and M665 H parameter with 0.075.

    @dc42
    I don't have a config-override.g


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.