Switching Heater to Standby sets standby temp to print temp



  • Reproduce steps:

    • Start print
    • pause and then abort print
    • klick on the "Heater 1" in the web ui
      -> Heater switches to standby but standby temp is set to print temp, so effectively doing nothing

    Version 1.21

    I'm pretty sure this was not the case in Version 1.17


  • administrators

    What's changed is that M104 and M109 commands now set both he active and the standby temperatures. This was done at the request of several users, because if your slicer generates M104 and/or M109 commands then it doesn't understand firmware that manages standby temperatures itself and it wants to control them directly. To let RepRapFirmware manage standby temperatures, configure your slicer to set temperatures using G10 instead.



  • Thanks for the explanation.
    I couldn't find how to change to G10 in Simplify3D and may just change the pause.g so it sets standby to 0.



  • For anyone looking for the solution to using G10 in stead of M104 and M109 in Simplify3D. It is explained on the page: https://forum.simplify3d.com/viewtopic.php?f=8&t=1959

    The relevant part is this (under starting G-Code):
    "If you're not a fan of the fact that Simplify3D heats up the bed/extruder, than runs your starting-script, you can customize this, by using the commands below. If you have the commands for [bed#_temperature] or [extruder#_temperature] in your starting G-Code script, the software won't add in heating commands, it will just run off of the commands in your starting script."

    So if we want to use G10 instead, we can simply prepend our starting Gcode Script (from the Scrips tab, and Starting Script tab) with something like this:

    M140 S[bed0_temperature] R40 ; set the active and standby temperatures for heatbed
    G10 P0 X0 Y0 Z0 S[extruder0_temperature] R155 ; set the active and standy temperatures
    M106 S[fan_speed_pwm] ; ensure our fan is at our starting speed, while we heat to our targets
    M116 ; wait for temperatures to reach their targets

    You can also, if you want to heat the heatbed first, add the wait (M116) also before setting the extruder temperatures.

    I have tested this and it works as we expect (S3D no longer adds its own heater instructions, and the starting temperature is what is st for Layer 0 in the temperature settings). Obviously the Standby temperature is set manually.

    Should you also want to set the heatbed and extruder to their standby temperatures, you can add the following to the ending script:

    T-1 ; set all tools to their standby temperatures

    This will allow you to easily continue with another print, (only heating up from the standby temps and not having to heat everything up again). In the DWC interface, while pr9inting there is an option "Enable Auto-Sleep" which will run M1 (Sleep or Conditional stop), which will shutdown heaters and motors when done.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.