U, V axes not working



  • I have added extra U and V axes to my delta printer on drivers 5&6 using Duex5. They worked several months ago, but a few things have changed, breaking functionality somewhere along the process. I had to redo my config file from scratch, so I am assuming part of the problem is just using G-codes out of order or something simple like that in my config file.

    I think I might be missing something simple. The axes show up in DWC, they "home" properly using homeu.g and homev.g. I say home in quotes because the homing files are extremely rudimentary right now:

    G92 U0 and G92 V0 respectively.

    I can attempt to jog the axes using DWC, but they don't move, and the machine status never updates to show the position the axes should be in after the move command. There are no errors displayed. The drivers work fine, because I can swap the X, Y, and Z axes to run off of the expansion board.

    Here is my current config file:

    [c]; Configuration file for Duet Ethernet (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Feb 26 2018 12:03:14 GMT-0600 (Central Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M665 R105.6 L215 B85 H250 ; Set delta radius, diagonal rod length, printable radius and homed height

    ; Network
    M550 PJohn's Duet ; Set machine name
    M540 Pbe:63:40:4c:53:52 ; Set MAC address
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S0 ; Drive 5 goes forwards
    M569 P6 S1 ; Drive 6 goes forwards
    M569 P7 S1 ; Drive 7 goes forwards

    M584 X0 Y1 Z2 E3 U5 V6 ; set up extra axes? U5 V6

    M350 X16 Y16 Z16 U16 V16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 U44.4444 V8 E663 ; Set steps per mm
    M566 X1200 Y1200 Z1200 U1200 V1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 U4000 V2000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 U1000 V1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 U1000 V1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    ;M84 S30 ; Set idle timeout

    ; Servos
    M307 H3 A-1 C-1 D-1 ; Disable heater 3-7. Set parameters to -1. Servos 3-7 are controlled with heaters 3-7 (There are no servos 1-2).
    M307 H4 A-1 C-1 D-1
    M307 H5 A-1 C-1 D-1
    M307 H6 A-1 C-1 D-1
    M307 H7 A-1 C-1 D-1

    ; Axis Limits
    M208 Z100 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 U0 V0 S1 ; Set active high endstops
    M666 X0 Y0 Z0 U0 V0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 R85 S20 ; Define mesh grid

    ; Heaters
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4725 C7.060000e-8 R4700; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Extruder" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 U0 V0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool
    M302 P1 ; Allow cold extrudes for testing[/c]

    Am I missing something?


  • administrators

    Try adding M208 upper and lower limits for U and V.



  • Yep that totally fixed it. I didn't realize those were needed. Fantastic! Thanks.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.